Author Topic: Slight problem  (Read 1153 times)

0 Members and 1 Guest are viewing this topic.

Offline Broseph Radson

  • LV5 Advanced (Next: 300)
  • *****
  • Posts: 295
  • Rating: +20/-1
  • Its 0x1A4 somewhere
    • View Profile
Slight problem
« on: April 11, 2011, 06:08:19 pm »
Im trying to display a percent sign, and both calcsys and xxedit show that the hax code for the percent sign is 25, but when i do Disp 25>Char it displays a greater than/equal sign instead ???

Offline Runer112

  • Project Author
  • LV11 Super Veteran (Next: 3000)
  • ***********
  • Posts: 2289
  • Rating: +639/-31
    • View Profile
Re: Slight problem
« Reply #1 on: April 11, 2011, 06:10:04 pm »
The percent symbol's character value is 25 in hexadecimal, but you're inputting it as a decimal value. So instead of displaying character 25h, it's really displaying character 17h, which is the less than or equal to symbol on the calculator. You want to use Disp ᴇ25►Dec. The before the number signifies that it's a hexadecimal value.
« Last Edit: April 11, 2011, 06:12:33 pm by Runer112 »

Ashbad

  • Guest
Re: Slight problem
« Reply #2 on: April 11, 2011, 06:10:25 pm »
Are you making it show the percent sign as a token, or as an ASCII character on calcsys?  Most ASCII characters have different token equates, disincluding numbers and letters.
« Last Edit: April 11, 2011, 06:12:37 pm by Ashbad »

Offline Broseph Radson

  • LV5 Advanced (Next: 300)
  • *****
  • Posts: 295
  • Rating: +20/-1
  • Its 0x1A4 somewhere
    • View Profile
Re: Slight problem
« Reply #3 on: April 11, 2011, 06:14:30 pm »
It worked! Thanks Runer :)