Author Topic: Commande Input sur OS 2.53MP patché  (Read 4607 times)

0 Members and 1 Guest are viewing this topic.

Offline Sandro

  • LV3 Member (Next: 100)
  • ***
  • Posts: 47
  • Rating: +0/-0
    • View Profile
Commande Input sur OS 2.53MP patché
« on: April 05, 2012, 01:29:14 pm »
Banjour,
je voudrais savoir quel est le problème du programme en axe suivant:
Code: [Select]
:.INPUT
:Input -> P

Quand je compile (dernière version d'axe parseur ; mode noShell), aucune erreur n'est signalée, par contre quand je lance l'éxécutable, la TI84+SE (avec l'OS 2.53MP patché avec polypatch84) plante : au début des affichages bizzards (dont souvent des caractères "curseuer") puis le graphique qui charcge puis recharge (juste les axe, j'ai pas testé avec des fonctions activées). les seuls effet que j'arive à optenir est de mettre en pause avec [entrer], d'obtenir une erreur mémoire en faisant [on] (mais si on valide le seul choix proposé (quitter), on revient au même état qu'avant) et d'éteindre (du moins l'écran). Un fois éteinte, il faut enlever les grosses piles pour pouvoir la ralumer.

Quelcun aurrait-il une idée de l'origine du problème et de la manière de le corriger?

Merci d'avance
Sandro

Offline Xeda112358

  • they/them
  • Moderator
  • LV12 Extreme Poster (Next: 5000)
  • ************
  • Posts: 4659
  • Rating: +718/-6
  • Calc-u-lator, do doo doo do do do.
    • View Profile
Re: Commande Input sur OS 2.53MP patché
« Reply #1 on: April 05, 2012, 05:01:20 pm »
o_O Je ne sais pas le problème, mais peut-être vous pouvez obtenir un screenie? Aussi, je pense que l'auteur de PolyPatch84 est Critor, mais les "patches" sont par BrandonW et thepenguin77 pour le pluspart. Donc, peut-être vous pouvez les demandez?

(erm, désolé pour la grammaire XD)

Offline DJ Omnimaga

  • Former TI programmer
  • CoT Emeritus
  • LV15 Omnimagician (Next: --)
  • *
  • Posts: 55851
  • Rating: +3151/-232
  • CodeWalrus founder & retired Omnimaga founder
    • View Profile
    • DJ Omnimaga Music
Re: Commande Input sur OS 2.53MP patché
« Reply #2 on: April 05, 2012, 05:34:24 pm »
Est-ce que tu as réussi à reproduire le même problème sur on OS 2.53MP non patché ainsi que 2.55MP et les vieux OS?
In case you are wondering where I went, I left Omni back in 2015 to form CodeWalrus due to various reasons explained back then, but I stopped calc dev in 2016 and am now mostly active on the CW Discord server at https://discord.gg/cuZcfcF



Official Website |T-Shirt store | Reverbnation | Facebook | Youtube | Twitter | Spotify

Offline Sandro

  • LV3 Member (Next: 100)
  • ***
  • Posts: 47
  • Rating: +0/-0
    • View Profile
Re: Commande Input sur OS 2.53MP patché
« Reply #3 on: April 06, 2012, 04:19:58 pm »
Personnelement, je ne me suis pas ammusé à changé d'OS pour l'instant pur tester vu le temps que ça prend.

Pour le screen, je vex bien, mais j'ai pas de rom avec l'OS 2.53MP patché pour TI84+SE. Donc quelcun aurait-il un moyen de récupérer le srceen direct sur la TI?

Merci d'avance
Sandro

PS : bonne ide de demander à critor, je le ferais quand j'aurais le temps

Offline DJ Omnimaga

  • Former TI programmer
  • CoT Emeritus
  • LV15 Omnimagician (Next: --)
  • *
  • Posts: 55851
  • Rating: +3151/-232
  • CodeWalrus founder & retired Omnimaga founder
    • View Profile
    • DJ Omnimaga Music
Re: Commande Input sur OS 2.53MP patché
« Reply #4 on: April 06, 2012, 05:25:34 pm »
Runer112 dit que ton code est correct, donc je crois que ton problème est PolyPatch. Il faudrait utiliser un OS 2.53 MP non-patché et vérifier, car il y a peut-être un conflit entre PolyPatch et Axe parser.
In case you are wondering where I went, I left Omni back in 2015 to form CodeWalrus due to various reasons explained back then, but I stopped calc dev in 2016 and am now mostly active on the CW Discord server at https://discord.gg/cuZcfcF



Official Website |T-Shirt store | Reverbnation | Facebook | Youtube | Twitter | Spotify

Offline Sandro

  • LV3 Member (Next: 100)
  • ***
  • Posts: 47
  • Rating: +0/-0
    • View Profile
Re: Commande Input sur OS 2.53MP patché
« Reply #5 on: April 07, 2012, 08:27:09 am »
Bon, je pense que je vais simplement revenir l'OS 2.43, vu que de toute façon en control je me sers de la 89titanium, donc j'ai pas trop besoin des quelques fonctions mathématiques de l'OS 2.53MP.

Sandro

EDIT : aucun problème sur OS 2.43 non patché
« Last Edit: April 07, 2012, 08:45:42 am by Sandro »

Offline DJ Omnimaga

  • Former TI programmer
  • CoT Emeritus
  • LV15 Omnimagician (Next: --)
  • *
  • Posts: 55851
  • Rating: +3151/-232
  • CodeWalrus founder & retired Omnimaga founder
    • View Profile
    • DJ Omnimaga Music
Re: Commande Input sur OS 2.53MP patché
« Reply #6 on: April 09, 2012, 03:31:34 am »
Ok donc ça doit être OS 2.53MP ou bien le patch.
In case you are wondering where I went, I left Omni back in 2015 to form CodeWalrus due to various reasons explained back then, but I stopped calc dev in 2016 and am now mostly active on the CW Discord server at https://discord.gg/cuZcfcF



Official Website |T-Shirt store | Reverbnation | Facebook | Youtube | Twitter | Spotify

Offline Sandro

  • LV3 Member (Next: 100)
  • ***
  • Posts: 47
  • Rating: +0/-0
    • View Profile
Re: Commande Input sur OS 2.53MP patché
« Reply #7 on: April 09, 2012, 03:58:34 am »
Oui, même si sur OS2.43 juste avec TI-Boy, j'ai encore quelques bugs mais moins graves (un token s'ajoute parfois(cf http://ourl.ca/15786).

Sandro