Author Topic: TiLP2 Transfer issues  (Read 4040 times)

0 Members and 1 Guest are viewing this topic.

Offline phenomist

  • LV4 Regular (Next: 200)
  • ****
  • Posts: 132
  • Rating: +46/-3
    • View Profile
TiLP2 Transfer issues
« on: March 20, 2011, 11:44:48 pm »
Argh... I'm getting errors when trying to transfer stuff from the computer to the calculator using TiLP2. It's giving me 0.0Kb/s speed, which, as we all know, is not downloading at all.

Help please?
Level Designer for Graviter

[Disclaimer: I can't program for my life.]

Offline Eeems

  • Mr. Dictator
  • Administrator
  • LV13 Extreme Addict (Next: 9001)
  • *************
  • Posts: 6229
  • Rating: +318/-36
  • little oof
    • View Profile
    • Eeems
Re: TiLP2 Transfer issues
« Reply #1 on: March 20, 2011, 11:57:34 pm »
Split this to a separate topic since it has little to do with the earlier posts of the other topic.
Have you gotten TiLP2 to work before?
/e

Offline JonimusPrime

  • LV6 Super Member (Next: 500)
  • ******
  • Posts: 389
  • Rating: +25/-5
    • View Profile
    • Jonimoose.net
Re: TiLP2 Transfer issues
« Reply #2 on: March 21, 2011, 12:06:42 am »
And what are you trying to send, to which calc, and with what cable.

"Always code as if the person who will maintain your code is a maniac serial killer that knows where you live" -Unknown

"If you've done something right no one will know that you've done anything at all" -Futurama

"Have a nice day, or not, the choice is yours." Tom Steiner

Offline phenomist

  • LV4 Regular (Next: 200)
  • ****
  • Posts: 132
  • Rating: +46/-3
    • View Profile
Re: TiLP2 Transfer issues
« Reply #3 on: March 21, 2011, 12:37:12 am »
I was trying to download the mario level in the original post.

It works when I send from Calculator to Computer. It doesn't work the other way around.

My computer is Windows XP, SP3, Media Center 2005 Edition.
My calculator is a TI-84+. I have a TI-84+ SE and a TI-Nspire with 84 emulation, if having such a calculator is absolutely critical to fixing the problem.
My cable is a generic USB cable. As I can send from calc to PC, I doubt it's a problem with the cable.
Level Designer for Graviter

[Disclaimer: I can't program for my life.]

Offline Lionel Debroux

  • LV11 Super Veteran (Next: 3000)
  • ***********
  • Posts: 2135
  • Rating: +290/-45
    • View Profile
    • TI-Chess Team
Re: TiLP2 Transfer issues
« Reply #4 on: March 21, 2011, 01:13:53 am »
Well, may I know what the original topic was, so that I can find the file and try to reproduce the problem ? :)

Thanks for the technical information about computer OS, calculator and cable.
Member of the TI-Chess Team.
Co-maintainer of GCC4TI (GCC4TI online documentation), TILP and TIEmu.
Co-admin of TI-Planet.

Offline phenomist

  • LV4 Regular (Next: 200)
  • ****
  • Posts: 132
  • Rating: +46/-3
    • View Profile
Re: TiLP2 Transfer issues
« Reply #5 on: March 21, 2011, 01:22:04 am »
Original topic: http://ourl.ca/9719

Hm it seems that the OS I'm running on my 84+ is 2.40
« Last Edit: March 21, 2011, 01:25:35 am by phenomist »
Level Designer for Graviter

[Disclaimer: I can't program for my life.]

Offline Lionel Debroux

  • LV11 Super Veteran (Next: 3000)
  • ***********
  • Posts: 2135
  • Rating: +290/-45
    • View Profile
    • TI-Chess Team
Re: TiLP2 Transfer issues
« Reply #6 on: March 21, 2011, 01:44:58 am »
Thanks.

I can transfer the file (and the other six files in that topic) to my 84+SE through DirectLink, using TILP II SVN HEAD, under Linux 64 bits (my development computer). All files were received on the first try. So it's probably not a problem with the file's size (which remains to be debugged on the 84+, after I debugged and fixed it on the Nspire several months ago and on the 89T yesterday).

EDIT: oh, wait - is TILP II hanging completely when you're trying to send those archived files to your 84+ ? I see in my console that the clamping of absurdly high delay values, which is preventing hangs due to the strange delay value (0xFFFFFFFF) imposed by the calc, went into action - and that is a post-TILP II 1.14 commit (which may be in the latest Windows build I made, though).
« Last Edit: March 21, 2011, 02:24:58 am by Lionel Debroux »
Member of the TI-Chess Team.
Co-maintainer of GCC4TI (GCC4TI online documentation), TILP and TIEmu.
Co-admin of TI-Planet.

Offline phenomist

  • LV4 Regular (Next: 200)
  • ****
  • Posts: 132
  • Rating: +46/-3
    • View Profile
Re: TiLP2 Transfer issues
« Reply #7 on: March 24, 2011, 02:34:15 am »
Yeah, it freezes, and I have to quit the command prompt, not the other graphical window.

(Specifically, it says delay=2^32-1)
« Last Edit: March 24, 2011, 02:35:58 am by phenomist »
Level Designer for Graviter

[Disclaimer: I can't program for my life.]

Offline Lionel Debroux

  • LV11 Super Veteran (Next: 3000)
  • ***********
  • Posts: 2135
  • Rating: +290/-45
    • View Profile
    • TI-Chess Team
Re: TiLP2 Transfer issues
« Reply #8 on: March 24, 2011, 02:39:44 am »
Try using http://lpg.ticalc.org/prj_tilp/beta/setup.exe instead :)

The latest build ( http://ourl.ca/4010/113171 ) was made months after than the commit that adds a workaround for those absurd delay values.
Member of the TI-Chess Team.
Co-maintainer of GCC4TI (GCC4TI online documentation), TILP and TIEmu.
Co-admin of TI-Planet.

Offline phenomist

  • LV4 Regular (Next: 200)
  • ****
  • Posts: 132
  • Rating: +46/-3
    • View Profile
Re: TiLP2 Transfer issues
« Reply #9 on: March 24, 2011, 03:57:29 am »
Cool, works very well! Thanks :D
Level Designer for Graviter

[Disclaimer: I can't program for my life.]

Offline Lionel Debroux

  • LV11 Super Veteran (Next: 3000)
  • ***********
  • Posts: 2135
  • Rating: +290/-45
    • View Profile
    • TI-Chess Team
Re: TiLP2 Transfer issues
« Reply #10 on: March 24, 2011, 04:10:17 am »
You're welcome. It's always good to see that the program is getting fixed before it bites more users ;)
Member of the TI-Chess Team.
Co-maintainer of GCC4TI (GCC4TI online documentation), TILP and TIEmu.
Co-admin of TI-Planet.

Offline Eeems

  • Mr. Dictator
  • Administrator
  • LV13 Extreme Addict (Next: 9001)
  • *************
  • Posts: 6229
  • Rating: +318/-36
  • little oof
    • View Profile
    • Eeems
Re: TiLP2 Transfer issues
« Reply #11 on: March 24, 2011, 02:09:33 pm »
I might also suggest upgrading your OS to 2.43, although that probably doesn't effect the issue at all.
/e