Author Topic: NSpire Lua  (Read 1420 times)

0 Members and 1 Guest are viewing this topic.

Offline hellninjas

  • LV7 Elite (Next: 700)
  • *******
  • Posts: 625
  • Rating: +17/-0
    • View Profile
NSpire Lua
« on: January 18, 2013, 12:35:19 pm »
I'd like to learn more about this as well, so I can actually get some projects out there! :3
Anyways, know a link where I could get started?

EDIT: I meant Lua, I typed Basic, derp.
« Last Edit: January 18, 2013, 01:56:24 pm by hellninjas »


Offline epic7

  • Chopin!
  • LV11 Super Veteran (Next: 3000)
  • ***********
  • Posts: 2200
  • Rating: +135/-8
  • I like robots
    • View Profile
Re: NSpire Lua
« Reply #2 on: January 18, 2013, 02:52:59 pm »
There's a bunch of Lua tutorials here:
http://www.inspired-lua.org/

Edit: ninja'd >_>
Just so this post isn't useless, here's an example program for a simple cube game I made a while ago: http://pastebin.com/5k0wacKw
« Last Edit: January 18, 2013, 02:55:40 pm by epic7 »

Offline hellninjas

  • LV7 Elite (Next: 700)
  • *******
  • Posts: 625
  • Rating: +17/-0
    • View Profile
Re: NSpire Lua
« Reply #3 on: January 18, 2013, 03:02:10 pm »
Thanks, i'll post my progress when I make something! :3

Offline Augs

  • LV6 Super Member (Next: 500)
  • ******
  • Posts: 306
  • Rating: +30/-29
    • View Profile
Re: NSpire Lua
« Reply #4 on: January 18, 2013, 05:00:19 pm »
You don't need 3.2 for LUA. All you need is 3.2 computer software. Then you do Insert --> Script editor --> Insert script. Then a window will pop up and you must type: platform.apilevel = "1.0". After that it is up to you.

Edit: This makes it possible to make LUA programs and have Ndless (using 3.1).
« Last Edit: January 18, 2013, 05:01:33 pm by Augs »