Author Topic: 84 Plus OS 2.71MP leaked: The beginning of the end of TI-84+ programming?  (Read 85746 times)

0 Members and 1 Guest are viewing this topic.

Offline DJ Omnimaga

  • Former TI programmer
  • CoT Emeritus
  • LV15 Omnimagician (Next: --)
  • *
  • Posts: 55851
  • Rating: +3151/-232
  • CodeWalrus founder & retired Omnimaga founder
    • View Profile
    • DJ Omnimaga Music
Re: A patch to fix 2.71MP
« Reply #180 on: April 01, 2011, 07:12:47 pm »
Wow I didn't realize they added/removed so much :/. GOod job, though, but I would keep the Nspire ad, in case in the final version teachers catch people with modified OSes when they see 2.71MP but a different message than the ad.
In case you are wondering where I went, I left Omni back in 2015 to form CodeWalrus due to various reasons explained back then, but I stopped calc dev in 2016 and am now mostly active on the CW Discord server at https://discord.gg/cuZcfcF



Official Website |T-Shirt store | Reverbnation | Facebook | Youtube | Twitter | Spotify

Offline Goplat

  • LV5 Advanced (Next: 300)
  • *****
  • Posts: 289
  • Rating: +81/-0
    • View Profile
Re: A patch to fix 2.71MP
« Reply #181 on: April 01, 2011, 07:21:21 pm »
I've been working on this all day and I think I've cleaned up the mess. This patch should fix 2.71MP.

I took care of:
-Parser Hook
-USB hook
-Asm(, AsmComp(, and AsmPrgm tokens, all reinstated and all working
-The random crashing
-ClrHome, Output(, Disp, and ClrDraw being slow
-Apps over 2 pages not running
-Output( not displaying in row 8
-Asm(, AsmComp(, and AsmPrgm no appearing in the catalog
-The weird advertisement
Did you also change the version number back to 2.55MP?
Numquam te deseram; numquam te deficiam; numquam circa curram et te desolabo
Numquam te plorare faciam; numquam valedicam; numquam mendacium dicam et te vulnerabo

Offline Deep Toaster

  • So much to do, so much time, so little motivation
  • Administrator
  • LV13 Extreme Addict (Next: 9001)
  • *************
  • Posts: 8209
  • Rating: +758/-15
    • View Profile
    • ClrHome
Re: A patch to fix 2.71MP
« Reply #182 on: April 01, 2011, 07:22:02 pm »
Ooh, can this be used to "unpatch" other OS versions?

Probably not.

EDIT: Apparently he did.
« Last Edit: April 01, 2011, 07:22:39 pm by Deep Thought »




Offline DJ Omnimaga

  • Former TI programmer
  • CoT Emeritus
  • LV15 Omnimagician (Next: --)
  • *
  • Posts: 55851
  • Rating: +3151/-232
  • CodeWalrus founder & retired Omnimaga founder
    • View Profile
    • DJ Omnimaga Music
Re: A patch to fix 2.71MP
« Reply #183 on: April 01, 2011, 07:42:16 pm »
Actually if he changed the number back to 2.55MP this would kinda be pointless, because people just have to re-install 2.55MP instead.

That's unless he wanted to make a patcher/unpatcher to quickly turn the OS from 2.55 to 2.71 back and forth, as some sort of teacher key.
In case you are wondering where I went, I left Omni back in 2015 to form CodeWalrus due to various reasons explained back then, but I stopped calc dev in 2016 and am now mostly active on the CW Discord server at https://discord.gg/cuZcfcF



Official Website |T-Shirt store | Reverbnation | Facebook | Youtube | Twitter | Spotify

Offline Xeda112358

  • they/them
  • Moderator
  • LV12 Extreme Poster (Next: 5000)
  • ************
  • Posts: 4659
  • Rating: +718/-6
  • Calc-u-lator, do doo doo do do do.
    • View Profile
Re: A patch to fix 2.71MP
« Reply #184 on: April 01, 2011, 07:44:19 pm »
Or he could simply edit OS 2.55MP to say 2.71 MP...

Offline Deep Toaster

  • So much to do, so much time, so little motivation
  • Administrator
  • LV13 Extreme Addict (Next: 9001)
  • *************
  • Posts: 8209
  • Rating: +758/-15
    • View Profile
    • ClrHome
Re: A patch to fix 2.71MP
« Reply #185 on: April 01, 2011, 07:47:19 pm »
Actually if he changed the number back to 2.55MP this would kinda be pointless, because people just have to re-install 2.55MP instead.

The patcher does change it to say "2.55MP," though (look in 2ND+[MEM] > 1:About...).




Offline DJ Omnimaga

  • Former TI programmer
  • CoT Emeritus
  • LV15 Omnimagician (Next: --)
  • *
  • Posts: 55851
  • Rating: +3151/-232
  • CodeWalrus founder & retired Omnimaga founder
    • View Profile
    • DJ Omnimaga Music
Re: A patch to fix 2.71MP
« Reply #186 on: April 01, 2011, 07:57:34 pm »
I see... well then I'm confused about the purpose, as to return to 2.55MP you can simply get a copy of 2.55MP. Or is it if 2.55MP would eventually vanish from TI site and to prevent people from having to search for a mirrored copy?
In case you are wondering where I went, I left Omni back in 2015 to form CodeWalrus due to various reasons explained back then, but I stopped calc dev in 2016 and am now mostly active on the CW Discord server at https://discord.gg/cuZcfcF



Official Website |T-Shirt store | Reverbnation | Facebook | Youtube | Twitter | Spotify

Offline thepenguin77

  • z80 Assembly Master
  • LV10 31337 u53r (Next: 2000)
  • **********
  • Posts: 1591
  • Rating: +823/-5
  • The game in my avatar is bit.ly/p0zPWu
    • View Profile
Re: A patch to fix 2.71MP
« Reply #187 on: April 01, 2011, 08:01:44 pm »
Why change the version to 2.71? Once you take out all the updates, it is 2.55.
zStart v1.3.013 9-20-2013 
All of my utilities
TI-Connect Help
You can build a statue out of either 1'x1' blocks or 12'x12' blocks. The 1'x1' blocks will take a lot longer, but the final product is worth it.
       -Runer112

Offline Deep Toaster

  • So much to do, so much time, so little motivation
  • Administrator
  • LV13 Extreme Addict (Next: 9001)
  • *************
  • Posts: 8209
  • Rating: +758/-15
    • View Profile
    • ClrHome
Re: A patch to fix 2.71MP
« Reply #188 on: April 01, 2011, 08:06:28 pm »
True, so why not download 2.55MP?

Or maybe TI did something useful in 2.71. Who knows.




Offline Darl181

  • «Yo buddy, you still alive?»
  • CoT Emeritus
  • LV12 Extreme Poster (Next: 5000)
  • *
  • Posts: 3408
  • Rating: +305/-13
  • VGhlIEdhbWU=
    • View Profile
    • darl181.webuda.com
Re: A patch to fix 2.71MP
« Reply #189 on: April 01, 2011, 09:01:58 pm »
Why change the version to 2.71? Once you take out all the updates, it is 2.55.
Updates?  Was anything updated?  This OS 2.71 looks like more downdating (?) to me :P
Good to see some of the problems solved, though.
« Last Edit: April 01, 2011, 09:02:22 pm by Darl181 »
Vy'o'us pleorsdti thl'e gjaemue

Offline Deep Toaster

  • So much to do, so much time, so little motivation
  • Administrator
  • LV13 Extreme Addict (Next: 9001)
  • *************
  • Posts: 8209
  • Rating: +758/-15
    • View Profile
    • ClrHome
Re: A patch to fix 2.71MP
« Reply #190 on: April 01, 2011, 09:02:36 pm »
Why change the version to 2.71? Once you take out all the updates, it is 2.55.
Updates?  Was anything updated?  This OS looks like more downdating (?) to me :P
Good to see some of the problems solved, though.

Downgrading?




Offline DJ Omnimaga

  • Former TI programmer
  • CoT Emeritus
  • LV15 Omnimagician (Next: --)
  • *
  • Posts: 55851
  • Rating: +3151/-232
  • CodeWalrus founder & retired Omnimaga founder
    • View Profile
    • DJ Omnimaga Music
Re: A patch to fix 2.71MP
« Reply #191 on: April 01, 2011, 09:06:34 pm »
Why change the version to 2.71? Once you take out all the updates, it is 2.55.
Well then people can't fool teachers making them think they got 2.71MP. That way they don't get told to upgrade. :P
In case you are wondering where I went, I left Omni back in 2015 to form CodeWalrus due to various reasons explained back then, but I stopped calc dev in 2016 and am now mostly active on the CW Discord server at https://discord.gg/cuZcfcF



Official Website |T-Shirt store | Reverbnation | Facebook | Youtube | Twitter | Spotify

Offline Compynerd255

  • LV6 Super Member (Next: 500)
  • ******
  • Posts: 336
  • Rating: +53/-4
  • Betafreak Games
    • View Profile
    • Betafreak Games
Re: A patch to fix 2.71MP
« Reply #192 on: April 01, 2011, 09:08:46 pm »
Great work, thepenguin! You should release a version of the OS with these patches applied. While you're at it, you could also mod the OS to include super-optimized routines, such as FastCopy instead of the slow routine. But that's another day. For now, fix that crummy OS!

EDIT:
Why change the version to 2.71? Once you take out all the updates, it is 2.55.
Well then people can't fool teachers making them think they got 2.71MP. That way they don't get told to upgrade. :P
Do teachers really have the right to fail you if you choose not to upgrade your OS? 2.43 and 2.55 work just fine.
« Last Edit: April 01, 2011, 09:10:21 pm by Compynerd255 »
The Slime: On Hold, preparing to add dynamic tiles

Axe Eitrix: DONE

Betafreak Games: Fun filled games for XBox and PC. Check it out at http://www.betafreak.com



Offline DJ Omnimaga

  • Former TI programmer
  • CoT Emeritus
  • LV15 Omnimagician (Next: --)
  • *
  • Posts: 55851
  • Rating: +3151/-232
  • CodeWalrus founder & retired Omnimaga founder
    • View Profile
    • DJ Omnimaga Music
Re: A patch to fix 2.71MP
« Reply #193 on: April 01, 2011, 09:10:21 pm »
I'M gonna merge this topic with the news and post a link to the patch in the first post, so the discussion won't risk spreading too much. X.x

EDIT: Done.
« Last Edit: April 01, 2011, 09:15:00 pm by DJ_O »
In case you are wondering where I went, I left Omni back in 2015 to form CodeWalrus due to various reasons explained back then, but I stopped calc dev in 2016 and am now mostly active on the CW Discord server at https://discord.gg/cuZcfcF



Official Website |T-Shirt store | Reverbnation | Facebook | Youtube | Twitter | Spotify

Offline thepenguin77

  • z80 Assembly Master
  • LV10 31337 u53r (Next: 2000)
  • **********
  • Posts: 1591
  • Rating: +823/-5
  • The game in my avatar is bit.ly/p0zPWu
    • View Profile
Great work, thepenguin! You should release a version of the OS with these patches applied. While you're at it, you could also mod the OS to include super-optimized routines, such as FastCopy instead of the slow routine. But that's another day. For now, fix that crummy OS!

EDIT:
Why change the version to 2.71? Once you take out all the updates, it is 2.55.
Well then people can't fool teachers making them think they got 2.71MP. That way they don't get told to upgrade. :P
Do teachers really have the right to fail you if you choose not to upgrade your OS? 2.43 and 2.55 work just fine.

If you really want the OS after all of my fixes are applied to 2.71, you should check the link in this post.
zStart v1.3.013 9-20-2013 
All of my utilities
TI-Connect Help
You can build a statue out of either 1'x1' blocks or 12'x12' blocks. The 1'x1' blocks will take a lot longer, but the final product is worth it.
       -Runer112