Author Topic: https by default  (Read 5580 times)

0 Members and 1 Guest are viewing this topic.

Offline TravisE

  • LV4 Regular (Next: 200)
  • ****
  • Posts: 182
  • Rating: +33/-0
    • View Profile
    • ticalc.org
Re: https by default
« Reply #15 on: December 08, 2014, 02:08:29 pm »
The site does load in https, but every link takes me back to the non-https version. Does that happen to anyone else, or is it just on my end?
ticalc.org staff member—http://www.ticalc.org/

Offline Sorunome

  • Fox Fox Fox Fox Fox Fox Fox!
  • Support Staff
  • LV13 Extreme Addict (Next: 9001)
  • *************
  • Posts: 7917
  • Rating: +373/-13
  • Derpy Hooves
    • View Profile
    • My website! (You might lose the game)
Re: https by default
« Reply #16 on: December 08, 2014, 02:45:17 pm »
The site does load in https, but every link takes me back to the non-https version. Does that happen to anyone else, or is it just on my end?
Maybe caching issues?

THE GAME
Also, check out my website
If OmnomIRC is screwed up, blame me!
Click here to give me an internet!

Offline Eeems

  • Mr. Dictator
  • Administrator
  • LV13 Extreme Addict (Next: 9001)
  • *************
  • Posts: 6167
  • Rating: +318/-36
  • C'est la vie
    • View Profile
    • Eeems
Re: https by default
« Reply #17 on: December 08, 2014, 03:10:55 pm »
Switching to HTTPS sure causes extreme server loading. It took 28 hours to load this page. :P


Oh wait nvm that was the host being down. :P Seriously I seriously hope you get some free months from this cuz it was kinda bad.

Also Moderation center is fixed, so I can't see it anymore. I didn't try to see if last post by the same IP errors still occur, though. I just noticed the site is back now.
I'm not getting any slow loading times. First load will be slow due to your browser not having anything cached. If it continues to do so, I'd suggest pinging me with your browsers network monitor output to see what's going on.
Nice but isn't this only a client <-> cf thing ? What about cf <-> omni ?
We're working on that. SSL certs cost money.
The last post from same ip still occurs, I had it when posting the above message which forced me to rewrite it. <_<
As mentioned before, this is a known problem. I'm not sure whats causing it yet, and from what I've done to look into it, this is not an issue isolated to Omnimaga, this is an SMF thing.
The site does load in https, but every link takes me back to the non-https version. Does that happen to anyone else, or is it just on my end?
Should have been fixed when I cleared all the old pretty url cached links. Could it be a chrome caching issue (if you use chrome)?
/e

Offline DJ Omnimaga

  • Now active at https://codewalr.us
  • CoT Emeritus
  • LV15 Omnimagician (Next: --)
  • *
  • Posts: 55821
  • Rating: +3151/-232
  • CodeWalrus founder & retired Omnimaga founder
    • View Profile
    • DJ Omnimaga Music
Re: https by default
« Reply #18 on: December 08, 2014, 05:04:08 pm »
The slowdown only lasted 5 minutes, after I discovered Omni was back, so don't worry.
In case you are wondering where I went, I left Omni back in 2015 to form CodeWalrus due to various reasons explained back then, but I stopped calc dev in 2016 and am now mostly active on the CW Discord server at https://discord.gg/cuZcfcF


Bandcamp|Reverbnation|Facebook|Youtube|Twitter

Offline Sorunome

  • Fox Fox Fox Fox Fox Fox Fox!
  • Support Staff
  • LV13 Extreme Addict (Next: 9001)
  • *************
  • Posts: 7917
  • Rating: +373/-13
  • Derpy Hooves
    • View Profile
    • My website! (You might lose the game)
Re: https by default
« Reply #19 on: December 09, 2014, 05:55:56 am »
Nightly now claims of some stuff being insecure and thus refuses to load like the stylesheet.

EDIT: I fixed it :)
« Last Edit: December 09, 2014, 08:19:04 am by Sorunome »

THE GAME
Also, check out my website
If OmnomIRC is screwed up, blame me!
Click here to give me an internet!

Offline Eeems

  • Mr. Dictator
  • Administrator
  • LV13 Extreme Addict (Next: 9001)
  • *************
  • Posts: 6167
  • Rating: +318/-36
  • C'est la vie
    • View Profile
    • Eeems
Re: https by default
« Reply #20 on: December 09, 2014, 10:08:28 am »
Nightly now claims of some stuff being insecure and thus refuses to load like the stylesheet.

EDIT: I fixed it :)
something keeps changing the board url setting back to http at random intervals :/
/e

Offline Streetwalrus

  • LV12 Extreme Poster (Next: 5000)
  • ************
  • Posts: 3820
  • Rating: +80/-8
    • View Profile
Re: https by default
« Reply #21 on: December 09, 2014, 10:37:04 am »
chattr +i settings.php

Just kidding but this can be used as a temporary solution. :P
send it

Offline Keoni29

  • LV11 Super Veteran (Next: 3000)
  • ***********
  • Posts: 2466
  • Rating: +291/-16
    • View Profile
    • My electronics projects at 8times8
Re: https by default
« Reply #22 on: December 09, 2014, 10:41:34 am »
Nightly now claims of some stuff being insecure and thus refuses to load like the stylesheet.

EDIT: I fixed it :)
something keeps changing the board url setting back to http at random intervals :/
Is this on the server side or on your client?
If you like my work: why not give me an internet?








Offline Sorunome

  • Fox Fox Fox Fox Fox Fox Fox!
  • Support Staff
  • LV13 Extreme Addict (Next: 9001)
  • *************
  • Posts: 7917
  • Rating: +373/-13
  • Derpy Hooves
    • View Profile
    • My website! (You might lose the game)
Re: https by default
« Reply #23 on: December 09, 2014, 01:16:00 pm »
Nightly now claims of some stuff being insecure and thus refuses to load like the stylesheet.

EDIT: I fixed it :)
something keeps changing the board url setting back to http at random intervals :/
Is this on the server side or on your client?
server-side but also fixed by now ;)

THE GAME
Also, check out my website
If OmnomIRC is screwed up, blame me!
Click here to give me an internet!

Offline Eeems

  • Mr. Dictator
  • Administrator
  • LV13 Extreme Addict (Next: 9001)
  • *************
  • Posts: 6167
  • Rating: +318/-36
  • C'est la vie
    • View Profile
    • Eeems
Re: https by default
« Reply #24 on: December 09, 2014, 01:19:59 pm »
Turns out our nightly backup is to blame. Forgot to change the settings files it's using :(
/e

Offline TravisE

  • LV4 Regular (Next: 200)
  • ****
  • Posts: 182
  • Rating: +33/-0
    • View Profile
    • ticalc.org
Re: https by default
« Reply #25 on: December 09, 2014, 09:03:37 pm »
The site does load in https, but every link takes me back to the non-https version. Does that happen to anyone else, or is it just on my end?
Should have been fixed when I cleared all the old pretty url cached links. Could it be a chrome caching issue (if you use chrome)?
I use Firefox, but it seems to be fixed now.
ticalc.org staff member—http://www.ticalc.org/

Offline Eeems

  • Mr. Dictator
  • Administrator
  • LV13 Extreme Addict (Next: 9001)
  • *************
  • Posts: 6167
  • Rating: +318/-36
  • C'est la vie
    • View Profile
    • Eeems
Re: https by default
« Reply #26 on: December 09, 2014, 09:21:14 pm »
The site does load in https, but every link takes me back to the non-https version. Does that happen to anyone else, or is it just on my end?
Should have been fixed when I cleared all the old pretty url cached links. Could it be a chrome caching issue (if you use chrome)?
I use Firefox, but it seems to be fixed now.
It was probably related to the backup resetting the base url.
/e

Offline DJ Omnimaga

  • Now active at https://codewalr.us
  • CoT Emeritus
  • LV15 Omnimagician (Next: --)
  • *
  • Posts: 55821
  • Rating: +3151/-232
  • CodeWalrus founder & retired Omnimaga founder
    • View Profile
    • DJ Omnimaga Music
Re: https by default
« Reply #27 on: December 10, 2014, 11:53:29 am »
As for the Last post by the same IP, I had it happen on Tapatalk as well earlier, except that on Tapatalk the problem is even worse: It deletes the post you were typing in the process. As a result, I can no longer post via Tapatalk.
In case you are wondering where I went, I left Omni back in 2015 to form CodeWalrus due to various reasons explained back then, but I stopped calc dev in 2016 and am now mostly active on the CW Discord server at https://discord.gg/cuZcfcF


Bandcamp|Reverbnation|Facebook|Youtube|Twitter