Author Topic: TILP: beta-testing...  (Read 52629 times)

0 Members and 1 Guest are viewing this topic.

Offline FloppusMaximus

  • LV5 Advanced (Next: 300)
  • *****
  • Posts: 290
  • Rating: +57/-5
    • View Profile
Re: TILP: beta-testing...
« Reply #195 on: April 18, 2013, 09:36:48 pm »
I've just checked, switching to interlaced mode does not have any apparent effect on screenshots.  The program you're using to switch the screen mode must be doing something else that interferes with screenshots.

Offline Lionel Debroux

  • LV11 Super Veteran (Next: 3000)
  • ***********
  • Posts: 2135
  • Rating: +290/-45
    • View Profile
    • TI-Chess Team
Re: TILP: beta-testing...
« Reply #196 on: May 05, 2013, 03:17:20 pm »
The TILP II 1.18 development cycle has officially started :)

Changes from TILP II 1.17 are few, but important:
* switched the development trees for libti*, gfm and tilp from SVN to Git. Two main repositories are used: libticonv + libtifiles + libticables + libticalcs on the one side ( https://github.com/debrouxl/tilibs ), gfm + tilp on the other side ( https://github.com/debrouxl/tilp_and_gfm ). The http://lpg.ticalc.org/prj_tilp/download/install_tilp.sh helper script has been updated, you need to re-download it !
* 84+CSE ROM dumping through both I/O ports, by Benjamin Moody;
* 84+CSE screenshots through both I/O ports, by Benjamin Moody (with minor torture tests and translation updates by me).

Sadly, I haven't yet been able to test the new changes on a real 84+CSE...

Mid-level functionality for Jonimus' ROM dumper shall be integrated by creating a fifth libti* library, and moving some common code from gfm, tilp, titools and probably tilem into "tiopers" (current working name for that new library). Jonimus' driver-less Windows serial port backend is planned to find its way into the libticables code base as well.

The usual links:
* Windows installer download: http://tiplanet.org/beta/setup.exe .
* Source code: https://github.com/debrouxl/tilibs + https://github.com/debrouxl/tilp_and_gfm .
* patches not yet committed to Git: none this time :)
* install script for anything non-Windows which is handled by TILP: http://lpg.ticalc.org/prj_tilp/download/install_tilp.sh (updated !).
Member of the TI-Chess Team.
Co-maintainer of GCC4TI (GCC4TI online documentation), TILP and TIEmu.
Co-admin of TI-Planet.

Offline DJ Omnimaga

  • Former TI programmer
  • CoT Emeritus
  • LV15 Omnimagician (Next: --)
  • *
  • Posts: 55851
  • Rating: +3151/-232
  • CodeWalrus founder & retired Omnimaga founder
    • View Profile
    • DJ Omnimaga Music
Re: TILP: beta-testing...
« Reply #197 on: May 05, 2013, 07:56:05 pm »
The TI-84 Plus C Silver Edition has two I/O ports? O.O Or do you mean the Mini USB port and actual I/O port?

Anyway I'M glad to see this update. I might try it when I have some time :)
« Last Edit: May 05, 2013, 07:57:45 pm by DJ Omnimaga »
In case you are wondering where I went, I left Omni back in 2015 to form CodeWalrus due to various reasons explained back then, but I stopped calc dev in 2016 and am now mostly active on the CW Discord server at https://discord.gg/cuZcfcF



Official Website |T-Shirt store | Reverbnation | Facebook | Youtube | Twitter | Spotify

Offline Hooloovoo

  • LV5 Advanced (Next: 300)
  • *****
  • Posts: 225
  • Rating: +22/-0
    • View Profile
Re: TILP: beta-testing...
« Reply #198 on: May 05, 2013, 08:06:40 pm »
A few things I have noticed with version 1.17:
the lack of a working silverlink OS sender
when you right click on windows, only one option shows up, and the rest are just separators. I can still click on the options, but I don't know what they say except that I have memorized the ones I use.
"My world is Black & White. But if I blink fast enough, I see it in Grayscale." -tr1p1ea
Spoiler For some of the calcs I own:



(actually I have quite a few more than this, but I don't feel like making bars for them all.)

Offline DJ Omnimaga

  • Former TI programmer
  • CoT Emeritus
  • LV15 Omnimagician (Next: --)
  • *
  • Posts: 55851
  • Rating: +3151/-232
  • CodeWalrus founder & retired Omnimaga founder
    • View Profile
    • DJ Omnimaga Music
Re: TILP: beta-testing...
« Reply #199 on: May 05, 2013, 09:25:17 pm »
Ok so it appears that ROM dumping for 84+CSE doesn't work under Windows XP SP3 (I'M using the version of TiLP you just posted, with a Direct USB cable and a TI-84 Plus C Silver Edition.)

-First, I make sure the calc is connected (I can see the files list), then I double-click Operating System
-Secondly I get the warning that ROMs are copyrighted by TI and I can't distribute/copy them and so on
-Third, I get the following message (and no ASM program gets sent to the calc):

Code: [Select]
An assembly program is about to be sent on your calculator.
If you have not made a backup yet, you should do one before
proceeding with ROM dumping...

For the way of proceeding, take a look at the TiLP manual
(especially if you have a USB cable).

-With Forward and Cancel as option, I click Forward
-Then this happens:



Another problem is that when you install TiLP and request a GTK+ download, if you use a 32 bit Windows install it appears to download the wrong version, because everytime I checked that option, neither TiLP/GTK theme selector would crash on startup, so I had to download it from GTK website everytime.
« Last Edit: May 05, 2013, 09:32:37 pm by DJ Omnimaga »
In case you are wondering where I went, I left Omni back in 2015 to form CodeWalrus due to various reasons explained back then, but I stopped calc dev in 2016 and am now mostly active on the CW Discord server at https://discord.gg/cuZcfcF



Official Website |T-Shirt store | Reverbnation | Facebook | Youtube | Twitter | Spotify

Offline Lionel Debroux

  • LV11 Super Veteran (Next: 3000)
  • ***********
  • Posts: 2135
  • Rating: +290/-45
    • View Profile
    • TI-Chess Team
Re: TILP: beta-testing...
« Reply #200 on: May 06, 2013, 03:25:00 pm »
Thanks for the report :)

Adriweb managed to get a ROM dump from his 84+CSE, so 84+CSE ROM dumping is at least not completely broken (anyhow, it worked for Benjamin before he sent me the patch). I should be able to get a 84+CSE in the next few months.

Quote
Another problem is that when you install TiLP and request a GTK+ download, if you use a 32 bit Windows install it appears to download the wrong version, because everytime I checked that option, neither TiLP/GTK theme selector would crash on startup, so I had to download it from GTK website everytime.
Odd. TILP being a 32-bit application, AFAICT, it's supposed to use the 32-bit GTK+ runtime.
What GTK+ runtime are you downloading (link) ?
Member of the TI-Chess Team.
Co-maintainer of GCC4TI (GCC4TI online documentation), TILP and TIEmu.
Co-admin of TI-Planet.

Offline DJ Omnimaga

  • Former TI programmer
  • CoT Emeritus
  • LV15 Omnimagician (Next: --)
  • *
  • Posts: 55851
  • Rating: +3151/-232
  • CodeWalrus founder & retired Omnimaga founder
    • View Profile
    • DJ Omnimaga Music
Re: TILP: beta-testing...
« Reply #201 on: May 06, 2013, 09:26:05 pm »
When I install TiLP it warns me that GTK+ isn't installed, but if I leave the Install GTK+ runtimes box checked, the installer will download them for me. Those are the ones that cause problems.

The ones linked at http://lpg.ticalc.org/prj_tilp/win32.html works fine.
In case you are wondering where I went, I left Omni back in 2015 to form CodeWalrus due to various reasons explained back then, but I stopped calc dev in 2016 and am now mostly active on the CW Discord server at https://discord.gg/cuZcfcF



Official Website |T-Shirt store | Reverbnation | Facebook | Youtube | Twitter | Spotify

Offline FloppusMaximus

  • LV5 Advanced (Next: 300)
  • *****
  • Posts: 290
  • Rating: +57/-5
    • View Profile
Re: TILP: beta-testing...
« Reply #202 on: May 07, 2013, 10:32:22 pm »
The ROM dumpers do work.  Must be something wrong with the Windows build.  Does ROM dumping work for other models?

the lack of a working silverlink OS sender
Elaborate, please.

Quote
when you right click on windows, only one option shows up, and the rest are just separators. I can still click on the options, but I don't know what they say except that I have memorized the ones I use.
I think I saw something similar at one point, probably because of a buggy version of GTK+.  The page DJ mentioned (http://lpg.ticalc.org/prj_tilp/win32.html) appears to be pointing to GTK+ 2.12.9, which is pretty old at this point.  The current TILP installer is using 2.24.8.

(I don't know why 2.24 would be crashing.  Try uninstalling both TILP and any old GTK+ packages, and installing everything anew?  There shouldn't be any 64-bit libraries involved, everything here is 32-bit except for the drivers.)
« Last Edit: May 07, 2013, 10:40:58 pm by FloppusMaximus »

Offline Hooloovoo

  • LV5 Advanced (Next: 300)
  • *****
  • Posts: 225
  • Rating: +22/-0
    • View Profile
Re: TILP: beta-testing...
« Reply #203 on: May 08, 2013, 10:31:28 am »
When I try to send an OS to my 83PSE or 84PSE, it gets through the point where the calculator says '0% Completed', and when it gets past sending the first page of the OS, the calculator says that there was an error, and the computer waits until the timeout time is past until it shows a timeout error. The direct USB OS sending works fine, and I can receive OSs from my friend's calculators with either link cable.

I am on a 32-bit system, so there shouldn't be any problem with 64-bit anythings.

Edit: I must have been on an old GTK, because when I uninstalled, and downloaded the GTK from the installer, the right clicking worked.
« Last Edit: May 08, 2013, 05:06:19 pm by fortytwo »
"My world is Black & White. But if I blink fast enough, I see it in Grayscale." -tr1p1ea
Spoiler For some of the calcs I own:



(actually I have quite a few more than this, but I don't feel like making bars for them all.)

Offline FloppusMaximus

  • LV5 Advanced (Next: 300)
  • *****
  • Posts: 290
  • Rating: +57/-5
    • View Profile
Re: TILP: beta-testing...
« Reply #204 on: May 08, 2013, 10:48:26 pm »
When I try to send an OS to my 83PSE or 84PSE, it gets through the point where the calculator says '0% Completed', and when it gets past sending the first page of the OS, the calculator says that there was an error, and the computer waits until the timeout time is past until it shows a timeout error. The direct USB OS sending works fine, and I can receive OSs from my friend's calculators with either link cable.
Thanks.  I don't know why it would be doing that, but I'll check it out.  To be clear, are you trying to send an official OS file from TI, or a third party OS?  Also, if you can, it'd be really helpful if you could post the log file (usually stored in "C:\Documents and Settings\username\.tilp.log") after trying to send an OS.

Offline Lionel Debroux

  • LV11 Super Veteran (Next: 3000)
  • ***********
  • Posts: 2135
  • Rating: +290/-45
    • View Profile
    • TI-Chess Team
Re: TILP: beta-testing...
« Reply #205 on: May 09, 2013, 04:06:24 pm »
I've created a new Windows build tonight.

Changes between the first TILP II 1.18 Windows beta build and this one:
* bugfix: applied patch by Benjamin for fixing 84+CSE screenshots;
* bugfix: removed "UsbKernel" option from the cables list in the TILP UI, that has been outdated for many years now (but people still occasionally try to use it);
* addition: functions for sending and receiving lesser-known DBUS commands (29 / 2A, 2B / 2C, 6E, 47 / 74) for the 83+ family. Missing: 89, CA, B7.

The usual links:
* Windows installer download: http://tiplanet.org/beta/setup.exe .
* Source code: https://github.com/debrouxl/tilibs + https://github.com/debrouxl/tilp_and_gfm .
* patches not yet committed to Git: http://tiplanet.org/beta/0001-libticalcs-add-support-for-several-DBUS-commands-for.patch .
* install script for anything non-Windows which is handled by TILP: http://lpg.ticalc.org/prj_tilp/download/install_tilp.sh .
Member of the TI-Chess Team.
Co-maintainer of GCC4TI (GCC4TI online documentation), TILP and TIEmu.
Co-admin of TI-Planet.

Offline Hooloovoo

  • LV5 Advanced (Next: 300)
  • *****
  • Posts: 225
  • Rating: +22/-0
    • View Profile
Re: TILP: beta-testing...
« Reply #206 on: May 09, 2013, 10:43:56 pm »
The log is attached. I am sending OS 2.53, I am almost positive it is signed, as the calculator does receive and validate over USB without a problem.
"My world is Black & White. But if I blink fast enough, I see it in Grayscale." -tr1p1ea
Spoiler For some of the calcs I own:



(actually I have quite a few more than this, but I don't feel like making bars for them all.)

Offline Lionel Debroux

  • LV11 Super Veteran (Next: 3000)
  • ***********
  • Posts: 2135
  • Rating: +290/-45
    • View Profile
    • TI-Chess Team
Re: TILP: beta-testing...
« Reply #207 on: May 29, 2013, 08:29:16 am »
(reading and replying to posts after the weeks of broken e-mail notifications which caused me to miss lots of topic updates)

We'll try to have a look in the next few days :)
Member of the TI-Chess Team.
Co-maintainer of GCC4TI (GCC4TI online documentation), TILP and TIEmu.
Co-admin of TI-Planet.

Offline DJ Omnimaga

  • Former TI programmer
  • CoT Emeritus
  • LV15 Omnimagician (Next: --)
  • *
  • Posts: 55851
  • Rating: +3151/-232
  • CodeWalrus founder & retired Omnimaga founder
    • View Profile
    • DJ Omnimaga Music
Re: TILP: beta-testing...
« Reply #208 on: June 10, 2013, 11:44:35 pm »
Notifications were broken for every single Omnimaga member except for XiiR3CR34T10N it seems, according to him, since he was getting them fine. :P

By the way is there any way to install Mallard on a TI-73 using TiLP? Some people have troubles with it it seems. It doesn't work in TI-Connect (anymore) either.
« Last Edit: June 10, 2013, 11:44:52 pm by DJ Omnimaga »
In case you are wondering where I went, I left Omni back in 2015 to form CodeWalrus due to various reasons explained back then, but I stopped calc dev in 2016 and am now mostly active on the CW Discord server at https://discord.gg/cuZcfcF



Official Website |T-Shirt store | Reverbnation | Facebook | Youtube | Twitter | Spotify

Offline Hooloovoo

  • LV5 Advanced (Next: 300)
  • *****
  • Posts: 225
  • Rating: +22/-0
    • View Profile
Re: TILP: beta-testing...
« Reply #209 on: June 11, 2013, 10:09:50 pm »
I am getting the weirdest error. When I try to run tilp, it cant find a dll that it needs

This seems with all versions when I try to install them.


also the release notes of 1.18 say:

         [ Release notes ]



Old     version:  1.16  (2011/12/15)
Current version:  1.17  (2013/03/31)


SubVersion (SVN) revision: $Id$
« Last Edit: June 11, 2013, 10:11:14 pm by fortytwo »
"My world is Black & White. But if I blink fast enough, I see it in Grayscale." -tr1p1ea
Spoiler For some of the calcs I own:



(actually I have quite a few more than this, but I don't feel like making bars for them all.)