Author Topic: Save in Zelda not working  (Read 204 times)

0 Members and 1 Guest are viewing this topic.

Offline EagleRaptor1522

  • LV0 Newcomer (Next: 5)
  • Posts: 4
  • Rating: +0/-0
    • View Profile
Save in Zelda not working
« on: January 11, 2022, 12:42:20 am »
This is a much older thread but I figured I'd try and see if I can get some help anyway

Got a TI-84 Plus SE from eBay specifically to put Zelda on.  Unfortunately the save function isn't working.  I used to have the same model calculator a few years ago where the save function worked, but unfortunately the calculator ended up broken

I'm not sure what I'm doing wrong.  I have what appears to be the latest version, 0.2.05, tried changing the backup battery.  Calculator keeps its normal history of calculations

Link's Awakening fits on the calculator, just doesn't save my game

Edit (Eeems): Split into it's own topic
« Last Edit: January 11, 2022, 01:36:35 pm by Eeems »

Offline Eeems

  • Mr. Dictator
  • Administrator
  • LV13 Extreme Addict (Next: 9001)
  • *************
  • Posts: 6248
  • Rating: +318/-36
  • little oof
    • View Profile
    • Eeems
Re: Save in Zelda not working
« Reply #1 on: January 11, 2022, 01:37:40 pm »
What happens when you try to save?
/e

Offline EagleRaptor1522

  • LV0 Newcomer (Next: 5)
  • Posts: 4
  • Rating: +0/-0
    • View Profile
Re: Save in Zelda not working
« Reply #2 on: January 11, 2022, 08:15:48 pm »
My save file is just gone upon exiting the emulator as if it were never played before, it otherwise plays as normal

The Calculator's OS is 2.43 also, if that helps

Offline Eeems

  • Mr. Dictator
  • Administrator
  • LV13 Extreme Addict (Next: 9001)
  • *************
  • Posts: 6248
  • Rating: +318/-36
  • little oof
    • View Profile
    • Eeems
Re: Save in Zelda not working
« Reply #3 on: January 14, 2022, 11:26:30 am »
@calc84maniac any ideas?
/e

Offline EagleRaptor1522

  • LV0 Newcomer (Next: 5)
  • Posts: 4
  • Rating: +0/-0
    • View Profile
Re: Save in Zelda not working
« Reply #4 on: January 14, 2022, 08:53:42 pm »
A little update, I ended up buying another calculator on ebay (the one on the right) which is running OS 2.40 and it retains the save file

I'm assuming a file called ZeldaDX1.8xv is the save file.  It's showing up on both calculators, but the one running OS 2.42 isn't reading it

Is there any way to get OS 2.40? I tried sending this OS to a newly bought 84 plus Non-SE and I keep getting error messages.  Though I think it may be from trying to go from a Silver to a non-silver, I don't really want to take that risk

Offline calc84maniac

  • eZ80 Guru
  • Coder Of Tomorrow
  • LV11 Super Veteran (Next: 3000)
  • ***********
  • Posts: 2903
  • Rating: +469/-17
    • View Profile
    • TI-Boy CE
Re: Save in Zelda not working
« Reply #5 on: January 19, 2022, 01:10:19 pm »
I don't think the OS version would be the problem, in fact OS 2.43 is probably what I ran it on the most. Could you check the model information on the back of the two calculators (if I recall, it should end with a 4-digit date code and a revision letter) just in case there's been some hardware change I don't know about?

Also, in terms of the Zelda game itself, I assume you probably know how to save since you got it working on one calculator, but just in case, unless you get a game over you have to press A+B+Start+Select to save the game.
"Most people ask, 'What does a thing do?' Hackers ask, 'What can I make it do?'" - Pablos Holman

Offline EagleRaptor1522

  • LV0 Newcomer (Next: 5)
  • Posts: 4
  • Rating: +0/-0
    • View Profile
Re: Save in Zelda not working
« Reply #6 on: January 20, 2022, 07:51:57 pm »
The one where the save works is S-0806F

The one that doesn't work is P-0809M (runs the game but doesn't save)

Both are Silver Editions

Running it on a newly bought 84+ (Zelda didn't fit so I tried Prince of Persia) looks terribly glitchy with sprites and numbers scattered everywhere lol