Author Topic: downgrade from 4.0.3 to 3.9 or lower  (Read 6573 times)

0 Members and 1 Guest are viewing this topic.

Offline j29614

  • LV0 Newcomer (Next: 5)
  • Posts: 1
  • Rating: +0/-0
    • View Profile
downgrade from 4.0.3 to 3.9 or lower
« on: February 26, 2016, 10:34:25 pm »
I recently bought a ti nspire cx and I jail broken it with endless on os version 4.0.3 with the last letter on the back of the calculator being "V" with a boot 2 code of 4.0.3.49.  D:
Is there any possible way for me to downgrade to a firmware that is lower than what I bought it on?
Is there a downgrade fix compatible with OS v 4.0.3?
I know that I can remove some root files (or data in them) to be able to make it so that I can downgrade but my friend bricked his calculator trying that so I don't want that.
« Last Edit: March 04, 2016, 01:20:48 am by j29614 »

Offline kitten

  • LV3 Member (Next: 100)
  • ***
  • Posts: 63
  • Rating: +0/-0
    • View Profile
Re: downgrade from 4.0.3 to 3.9 or lower
« Reply #1 on: May 30, 2016, 10:54:04 am »
Step 1. Download nsNandMgr: https://tiplanet.org/forum/archives_voir.php?id=10080
Step 2. Extract nsNandMgr.tns and place it on the calculator.
Step 3. Launch the program and enter your TI-Nspire hardware revision (in your case, V).
Step 4. Press 5 to go to the boot data options.
Step 5. Press 7 to remove the downgrade protection. Wait for the operation to complete.
Step 6. Press esc twice to exit the application.
Step 7. Connect your calculator to your computer, and install any TI-Nspire CX OS, as long as it is version 3.9.1 or above (hardware revision V restrictions).
Step 8. Set up your calculator again, install Ndless, and you're good to go!
Not to be confused with Harry Truman.

Offline eduardo_njr

  • LV0 Newcomer (Next: 5)
  • Posts: 2
  • Rating: +0/-0
    • View Profile
Re: downgrade from 4.0.3 to 3.9 or lower
« Reply #2 on: September 06, 2016, 11:12:08 am »
Following this steps, could I install the CAS OS on a non-CAS CX with serial number "P-xxxxN" ?

Offline kitten

  • LV3 Member (Next: 100)
  • ***
  • Posts: 63
  • Rating: +0/-0
    • View Profile
Re: downgrade from 4.0.3 to 3.9 or lower
« Reply #3 on: September 20, 2016, 12:58:11 pm »
Following this steps, could I install the CAS OS on a non-CAS CX with serial number "P-xxxxN" ?

Sorry, you can only install CAS CX on a non-CAS CX with a revision less than J (less than P-xxxxJ, for example P-xxxxI or P-xxxxE).
However, you can install nBoot+ControlX, and at some point it may be possible to accomplish such a feat using the aforementioned programs.
Not to be confused with Harry Truman.

Offline Maximilian Wegener

  • LV0 Newcomer (Next: 5)
  • Posts: 2
  • Rating: +0/-0
    • View Profile
Re: downgrade from 4.0.3 to 3.9 or lower
« Reply #4 on: October 27, 2016, 04:03:27 pm »
Hey guys!
Ive tried downgrading 4.2 pn my ti nspire cx using your tutorial.My first question is where do I have to enter my hardware revision in nsnandmrg?I have the hw revision Y and I am curious if this is even working for me (is it???). I have tried it without entering my hw revision because I dont know where so I set my min os to 0.0 and tried to install 3.9.1.The problem is when it boots and has finished loading half of the screen goes black and I cant do anything.Then Ive tried the same installing 4.0.3 which worked and I could get into the menu and it also said my version was 4.03. But the problem on this version is that my device reboots everytime I press ctr plus w to install ndless(and I used the right ndless version file).So on this version I cant even install ndless... Is there any option I can get this to work???Because gba emulators run rally slow in compatibility mode and I need to get it on the last version supported to run faster (4.0).Is there any way???????

Offline kitten

  • LV3 Member (Next: 100)
  • ***
  • Posts: 63
  • Rating: +0/-0
    • View Profile
Re: downgrade from 4.0.3 to 3.9 or lower
« Reply #5 on: November 01, 2016, 09:17:59 pm »
Hey guys!
Ive tried downgrading 4.2 pn my ti nspire cx using your tutorial.My first question is where do I have to enter my hardware revision in nsnandmrg?I have the hw revision Y and I am curious if this is even working for me (is it???). I have tried it without entering my hw revision because I dont know where so I set my min os to 0.0 and tried to install 3.9.1.The problem is when it boots and has finished loading half of the screen goes black and I cant do anything.Then Ive tried the same installing 4.0.3 which worked and I could get into the menu and it also said my version was 4.03. But the problem on this version is that my device reboots everytime I press ctr plus w to install ndless(and I used the right ndless version file).So on this version I cant even install ndless... Is there any option I can get this to work???Because gba emulators run rally slow in compatibility mode and I need to get it on the last version supported to run faster (4.0).Is there any way???????

Only hardware revisions equal to or less than V can downgrade to anything lower than 4.3. Your calculator, a revision Y, is stuck on 4.2 in compatibility mode forever. This is unlikely to change, as the hardware itself updated and can not be changed via a software downgrade. Your best option is to sell your calculator and buy an older one from Ebay or something, preferably a revision I or less if you want nLaunchy or nBoot+ControlX or revision V or less if you only want nBoot+ControlX.
Not to be confused with Harry Truman.

Offline Maximilian Wegener

  • LV0 Newcomer (Next: 5)
  • Posts: 2
  • Rating: +0/-0
    • View Profile
Re: downgrade from 4.0.3 to 3.9 or lower
« Reply #6 on: November 02, 2016, 02:15:21 pm »
Thanks for your reply!
But will there ever be a gba emulator for 4.2 so I wouldnt have to run it in compatability mode?

Offline kitten

  • LV3 Member (Next: 100)
  • ***
  • Posts: 63
  • Rating: +0/-0
    • View Profile
Re: downgrade from 4.0.3 to 3.9 or lower
« Reply #7 on: November 02, 2016, 09:20:31 pm »
Thanks for your reply!
But will there ever be a gba emulator for 4.2 so I wouldnt have to run it in compatability mode?

It will probably take a very long time, if at all. There was never any source code posted for the GBA emulator, so it would have to be rebuilt from scratch. You might want to look and ask around at places like Codewalrus and Cemetech, as the Nspire section of Omnimaga is pretty dead.
Not to be confused with Harry Truman.

Offline SpiroH

  • LV8 Addict (Next: 1000)
  • ********
  • Posts: 711
  • Rating: +153/-23
    • View Profile
Re: downgrade from 4.0.3 to 3.9 or lower
« Reply #8 on: November 02, 2016, 09:51:28 pm »
.... There was never any source code posted for the GBA emulator...
Well, AFAICT you still can find the GBA emulator gpSP-Nspire source code here:
https://www.omnimaga.org/ti-nspire-projects/gpsp-nspire-(gba-emulator)/msg314055/#msg314055

Have fun  ;)

Offline kitten

  • LV3 Member (Next: 100)
  • ***
  • Posts: 63
  • Rating: +0/-0
    • View Profile
Re: downgrade from 4.0.3 to 3.9 or lower
« Reply #9 on: November 03, 2016, 05:35:20 pm »
Well, AFAICT you still can find the GBA emulator gpSP-Nspire source code here:
https://www.omnimaga.org/ti-nspire-projects/gpsp-nspire-(gba-emulator)/msg314055/#msg314055

Have fun  ;)

Oh, that's swell! Hopefully someone will update the code and fix it for the new screens. That someone won't be me, that's for sure; I've got no idea how to write code (other than very basic Python). I'm planning on learning though :)
Not to be confused with Harry Truman.

Offline SpiroH

  • LV8 Addict (Next: 1000)
  • ********
  • Posts: 711
  • Rating: +153/-23
    • View Profile
Re: downgrade from 4.0.3 to 3.9 or lower
« Reply #10 on: November 06, 2016, 10:23:51 am »
Oh, that's swell! Hopefully someone will update the code and fix it for the new screens.
Well, I wish the next calc would be a gamulator, one with good-sound and internet.  :)
Some of my students do listen to music (with phones) while making programs. I really don't care that much, though, as they look happy and concentrated.

Offline kitten

  • LV3 Member (Next: 100)
  • ***
  • Posts: 63
  • Rating: +0/-0
    • View Profile
Re: downgrade from 4.0.3 to 3.9 or lower
« Reply #11 on: November 14, 2016, 08:17:05 pm »
Well, I wish the next calc would be a gamulator, one with good-sound and internet.  :)

Sound? Internet? On a calculator? Surely you jest, something like that would never be allowed in a school  ;)
But with the power of soldering irons, nothing will stand in the way! Except maybe NAND corruption, which I think my Nspire decided to acquire. Such perfect timing, it was right when I was about to do math homework :P
Not to be confused with Harry Truman.

Offline SpiroH

  • LV8 Addict (Next: 1000)
  • ********
  • Posts: 711
  • Rating: +153/-23
    • View Profile
Re: downgrade from 4.0.3 to 3.9 or lower
« Reply #12 on: November 15, 2016, 04:48:59 pm »
But with the power of soldering irons, nothing will stand in the way! Except maybe NAND corruption, which I think my Nspire decided to acquire.
LOL, have you tried a clothes iron instead? They normally throw out steam which can be good for sore throats and will possibly also iron out some weird NAND flash bug, btw.
Quote
Such perfect timing, it was right when I was about to do math homework :P
'Murphy's law' rings the bell? Sense of humour normally helps you to go through these ordeals. (They're certainly softer than the simple thought of having someone like Trump for president  :P).