Author Topic: Install script for PrizmSDK [*nix]  (Read 4844 times)

0 Members and 1 Guest are viewing this topic.

Offline Mighty Moose

  • LV4 Regular (Next: 200)
  • ****
  • Posts: 141
  • Rating: +4/-0
    • View Profile
Install script for PrizmSDK [*nix]
« on: September 12, 2012, 11:30:38 pm »
Hi everyone!

This is a little shell script I wrote to automate the installation of the Prizm SDK (binutils, gcc, mkg3a, and libfxcg) onto your computer.  Plop this into any directory and run it with 'sudo sh ./install_prizm_sdk.sh'. Run 'export PATH=$PATH:/usr/local/cross/bin' or modify your PATH in a suitable manner after it has completed installation, and enjoy!  Currently, this script installs gcc/binutils to /usr/local/cross/bin and the PrizmSDK (libfxcg) to /home/{username}/PrizmSDK by default, but this is able to be easily modified.  Please read the comments in the script itself for further (but not exhaustive) information on what development libraries and utility programs you may need to retrieve to successfully install the SDK and other ways to modify or customize this script.

Questions? Comments? Snide Remarks?
Feel free to reply here, pm me, or email me.

Cheers and happy programming! :thumbsup:
MM
Cheers!
I beta test, so...yeah.  PM me if you want me to test anything :D.

Almost only counts in horseshoes and handgrenades.

Cogito ergo sum.

Calcs:
TI-84+, OS 2.43, Boot Code 1.02, 128k RAM
TI-84+SE VSC, OS 2.43, Boot Code 1.00, 128k RAM  (I'm spoiled :P)
TI-81, OS 1.6K (only borrowed)
Casio fx-CG10 (Prizm), OS 01.04.0200
TI-Nspire Clickpad, OS 1.4
TI-Nspire Clickpad, OS 3.1.0.392
TI-Nspire CAS Clickpad, OS 1.6.10110 (!?) now OS 3.1.0.392

Offline Juju

  • Incredibly sexy mare
  • Coder Of Tomorrow
  • LV13 Extreme Addict (Next: 9001)
  • *************
  • Posts: 5730
  • Rating: +500/-19
  • Weird programmer
    • View Profile
    • juju2143's shed
Re: Install script for PrizmSDK [*nix]
« Reply #1 on: September 13, 2012, 01:15:35 pm »
Nice script here.

On Arch Linux, binutils, gcc and mkg3a are all available from the AUR, so "yaourt -S cross-sh3eb-elf-binutils cross-sh3eb-elf-gcc mkg3a && git clone https://github.com/Jonimoose/libfxcg.git PrizmSDK" should work (replace yaourt with whatever script you use to retrieve packages from the AUR).
« Last Edit: September 13, 2012, 01:16:25 pm by Juju »

Remember the day the walrus started to fly...

I finally cleared my sig after 4 years you're happy now?
THEGAME
This signature is ridiculously large you've been warned.

The cute mare that used to be in my avatar is Yuki Kagayaki, you can follow her on Facebook and Tumblr.

Offline DJ Omnimaga

  • Clacualters are teh gr33t
  • CoT Emeritus
  • LV15 Omnimagician (Next: --)
  • *
  • Posts: 55942
  • Rating: +3154/-232
  • CodeWalrus founder & retired Omnimaga founder
    • View Profile
    • Dream of Omnimaga Music
Re: Install script for PrizmSDK [*nix]
« Reply #2 on: September 13, 2012, 04:18:16 pm »
Seems pretty nice :D. This always uses the latest version of the SDK stuff btw, tho?
Now active at https://discord.gg/cuZcfcF (CodeWalrus server)

Offline Eiyeron

  • Urist McEiyolobster
  • LV10 31337 u53r (Next: 2000)
  • **********
  • Posts: 1430
  • Rating: +130/-10
  • (-_(//));
    • View Profile
    • Rétro-Actif : Rétro/Prog/Blog
Re: Install script for PrizmSDK [*nix]
« Reply #3 on: September 13, 2012, 04:45:39 pm »
GOnna love it, I'll go Debian because my school uses it! p:

Offline Juju

  • Incredibly sexy mare
  • Coder Of Tomorrow
  • LV13 Extreme Addict (Next: 9001)
  • *************
  • Posts: 5730
  • Rating: +500/-19
  • Weird programmer
    • View Profile
    • juju2143's shed
Re: Install script for PrizmSDK [*nix]
« Reply #4 on: September 13, 2012, 10:14:11 pm »
Seems pretty nice :D. This always uses the latest version of the SDK stuff btw, tho?
Yeah, I checked, it downloads the SDK using Git, so it's always the latest version. (That might or might not compile. If it fails, just yell at Tari on Cemetech.)

Remember the day the walrus started to fly...

I finally cleared my sig after 4 years you're happy now?
THEGAME
This signature is ridiculously large you've been warned.

The cute mare that used to be in my avatar is Yuki Kagayaki, you can follow her on Facebook and Tumblr.

Offline Mighty Moose

  • LV4 Regular (Next: 200)
  • ****
  • Posts: 141
  • Rating: +4/-0
    • View Profile
Re: Install script for PrizmSDK [*nix]
« Reply #5 on: September 14, 2012, 11:54:33 am »
Nice script here.

On Arch Linux, binutils, gcc and mkg3a are all available from the AUR, so "yaourt -S cross-sh3eb-elf-binutils cross-sh3eb-elf-gcc mkg3a && git clone https://github.com/Jonimoose/libfxcg.git PrizmSDK" should work (replace yaourt with whatever script you use to retrieve packages from the AUR).

Hey thanks! (On a side note: this is one of the first shell scripts I have ever written :P)

Seems pretty nice :D. This always uses the latest version of the SDK stuff btw, tho?

Yup.  If you really want, you (or I) can change it so it uses a more "stable" version a la PrizmSDK-0.3, or just take Juju's advice.  Everything else is configurable through variables (e.g. I had the best luck with gcc-4.6.3, but you can change that to whatever you want).
Cheers!
I beta test, so...yeah.  PM me if you want me to test anything :D.

Almost only counts in horseshoes and handgrenades.

Cogito ergo sum.

Calcs:
TI-84+, OS 2.43, Boot Code 1.02, 128k RAM
TI-84+SE VSC, OS 2.43, Boot Code 1.00, 128k RAM  (I'm spoiled :P)
TI-81, OS 1.6K (only borrowed)
Casio fx-CG10 (Prizm), OS 01.04.0200
TI-Nspire Clickpad, OS 1.4
TI-Nspire Clickpad, OS 3.1.0.392
TI-Nspire CAS Clickpad, OS 1.6.10110 (!?) now OS 3.1.0.392

Offline Juju

  • Incredibly sexy mare
  • Coder Of Tomorrow
  • LV13 Extreme Addict (Next: 9001)
  • *************
  • Posts: 5730
  • Rating: +500/-19
  • Weird programmer
    • View Profile
    • juju2143's shed
Re: Install script for PrizmSDK [*nix]
« Reply #6 on: September 14, 2012, 02:54:58 pm »
gcc-4.7.0 works fine for me.

Remember the day the walrus started to fly...

I finally cleared my sig after 4 years you're happy now?
THEGAME
This signature is ridiculously large you've been warned.

The cute mare that used to be in my avatar is Yuki Kagayaki, you can follow her on Facebook and Tumblr.