Author Topic: Faster Flash Access for the 83+/84+  (Read 12560 times)

0 Members and 1 Guest are viewing this topic.

Offline DJ Omnimaga

  • Former TI programmer
  • CoT Emeritus
  • LV15 Omnimagician (Next: --)
  • *
  • Posts: 55851
  • Rating: +3151/-232
  • CodeWalrus founder & retired Omnimaga founder
    • View Profile
    • DJ Omnimaga Music
Re: Faster Flash Access for the 83+/84+
« Reply #30 on: November 11, 2012, 10:44:01 pm »
Ok I see. I was a bit worried in case there were stuff like how TI-Boy used to fail on newer hardware.
In case you are wondering where I went, I left Omni back in 2015 to form CodeWalrus due to various reasons explained back then, but I stopped calc dev in 2016 and am now mostly active on the CW Discord server at https://discord.gg/cuZcfcF



Official Website |T-Shirt store | Reverbnation | Facebook | Youtube | Twitter | Spotify

Offline squidgetx

  • Food.
  • CoT Emeritus
  • LV10 31337 u53r (Next: 2000)
  • *
  • Posts: 1881
  • Rating: +503/-17
  • rawr.
    • View Profile
Re: Faster Flash Access for the 83+/84+
« Reply #31 on: November 12, 2012, 09:41:38 am »
Which OS? I had to do this 5 times, so there's a chance I made a mistake in one of them.

2.43, 84+SE. I haven't had the chance to reapply the patch yet, but since resending the OS everything's been fine =/.

Offline Happybobjr

  • James Oldiges
  • LV11 Super Veteran (Next: 3000)
  • ***********
  • Posts: 2325
  • Rating: +128/-20
  • Howdy :)
    • View Profile
Re: Faster Flash Access for the 83+/84+
« Reply #32 on: November 18, 2012, 11:55:24 am »
in 2.55 it the calc crashes when opening mirageos and zstart in classic mode, and freezes in mathprint.

However, 2.55 is so buggy anyways, i'm not sure why i was using it.
School: East Central High School
 
Axe: 1.0.0
TI-84 +SE  ||| OS: 2.53 MP (patched) ||| Version: "M"
TI-Nspire    |||  Lent out, and never returned
____________________________________________________________

Offline TexasInstruments84

  • LV2 Member (Next: 40)
  • **
  • Posts: 24
  • Rating: +0/-0
    • View Profile
Re: Faster Flash Access for the 83+/84+
« Reply #33 on: March 16, 2013, 06:09:23 pm »
Looks like my calculator died. Doesn't recognize it through USB, so I can't restore it. Any solutions?

This is what it does when I hold clear and ON. It goes to this screen and becomes blank again. :[

And yes, I did use the correct version. I waited until the program finished (never did), crashed, and now it's dead.

« Last Edit: March 16, 2013, 06:20:42 pm by TexasInstruments84 »

Offline tifreak

  • LV11 Super Veteran (Next: 3000)
  • ***********
  • Posts: 2708
  • Rating: +82/-3
  • My Kung Fu IS strong...
    • View Profile
    • TI-Freakware
Re: Faster Flash Access for the 83+/84+
« Reply #34 on: March 16, 2013, 06:26:45 pm »
Pull a battery. Press and hold ON and DEL, then reinsert battery. It should ask for an OS at that point.
Projects: AOD Series: 75% | FFME: 80% | Pokemon: 18% | RPGSK: 60% | Star Trek: 70% | Star Trek 83+: 40% | TI-City: 5%

Offline TexasInstruments84

  • LV2 Member (Next: 40)
  • **
  • Posts: 24
  • Rating: +0/-0
    • View Profile
Re: Faster Flash Access for the 83+/84+
« Reply #35 on: March 16, 2013, 06:34:42 pm »
Thanks for the help! Once it restores, I'm going to try to find a solution to the key response problem. I'll update this soon.

Update: looks like this program doesn't like zstart. I tried opening it but it just froze.
« Last Edit: March 16, 2013, 06:48:12 pm by TexasInstruments84 »

Offline Runer112

  • Moderator
  • LV11 Super Veteran (Next: 3000)
  • ***********
  • Posts: 2289
  • Rating: +639/-31
    • View Profile
Re: Faster Flash Access for the 83+/84+
« Reply #36 on: September 08, 2013, 04:08:55 pm »
I am now fairly sure that this patch has at least one negative side effect. I have reports from two users of this patch that, with it installed, scrolling to errors from Axe results in garbage being displayed, corruption of RAM, and possibly other issues (now that I'm testing it again in Wabbitemu, the OS will not boot after the issue occurs). After a short amount of testing, it appears that the error can be triggered not just by instant error scrolling from Axe, but also from DoorsCS. The OS version may or may not matter; both users who reported the issue use 2.43.

Offline Streetwalrus

  • LV12 Extreme Poster (Next: 5000)
  • ************
  • Posts: 3821
  • Rating: +80/-8
    • View Profile
Re: Faster Flash Access for the 83+/84+
« Reply #37 on: September 09, 2013, 12:46:51 pm »
Oooohh that's why. XD But I archive so often that this patch is pretty much a must for me. I hope it can be fixed though.

Offline Sorunome

  • Fox Fox Fox Fox Fox Fox Fox!
  • Support Staff
  • LV13 Extreme Addict (Next: 9001)
  • *************
  • Posts: 7918
  • Rating: +374/-13
  • Derpy Hooves
    • View Profile
    • My website! (You might lose the game)
Re: Faster Flash Access for the 83+/84+
« Reply #38 on: September 09, 2013, 02:02:38 pm »
i didn't experience any errors when i used that patch ???

THE GAME
Also, check out my website
If OmnomIRC is screwed up, blame me!
Click here to give me an internet!

Offline Eiyeron

  • Urist McEiyolobster
  • LV10 31337 u53r (Next: 2000)
  • **********
  • Posts: 1430
  • Rating: +130/-10
  • (-_(//));
    • View Profile
    • Rétro-Actif : Rétro/Prog/Blog
Re: Faster Flash Access for the 83+/84+
« Reply #39 on: September 09, 2013, 03:00:03 pm »
Try making a syntax error in Axe, then savour the scroll...

Offline TIfanx1999

  • ಠ_ಠ ( ͡° ͜ʖ ͡°)
  • CoT Emeritus
  • LV13 Extreme Addict (Next: 9001)
  • *
  • Posts: 6173
  • Rating: +191/-9
    • View Profile
Re: Faster Flash Access for the 83+/84+
« Reply #40 on: September 09, 2013, 03:06:47 pm »
Eiyeron: Was this what was causing your troubles? O_o

Offline Eiyeron

  • Urist McEiyolobster
  • LV10 31337 u53r (Next: 2000)
  • **********
  • Posts: 1430
  • Rating: +130/-10
  • (-_(//));
    • View Profile
    • Rétro-Actif : Rétro/Prog/Blog
Re: Faster Flash Access for the 83+/84+
« Reply #41 on: September 09, 2013, 03:09:32 pm »
Stupid syntax error like Lbl function(), or unknown variables, like a uninit Pic007 for instance. Each error make me comes into Axe using zStart instant scoll-to-error, and persisted to use it, even when accessing on a flash program...

Offline DJ Omnimaga

  • Former TI programmer
  • CoT Emeritus
  • LV15 Omnimagician (Next: --)
  • *
  • Posts: 55851
  • Rating: +3151/-232
  • CodeWalrus founder & retired Omnimaga founder
    • View Profile
    • DJ Omnimaga Music
Re: Faster Flash Access for the 83+/84+
« Reply #42 on: September 10, 2013, 01:05:11 am »
I personally avoided using goto error during Axe compiling, because in many cases it scrolled forever through garbage for me anyway, so I had the habit to just quit then go edit my program afterward. :P

I wonder what in the faster flash program could be causing the errors, though... ???
« Last Edit: September 10, 2013, 01:05:41 am by DJ Omnimaga »
In case you are wondering where I went, I left Omni back in 2015 to form CodeWalrus due to various reasons explained back then, but I stopped calc dev in 2016 and am now mostly active on the CW Discord server at https://discord.gg/cuZcfcF



Official Website |T-Shirt store | Reverbnation | Facebook | Youtube | Twitter | Spotify

Offline Streetwalrus

  • LV12 Extreme Poster (Next: 5000)
  • ************
  • Posts: 3821
  • Rating: +80/-8
    • View Profile
Re: Faster Flash Access for the 83+/84+
« Reply #43 on: September 10, 2013, 06:23:46 am »
Maybe a weird combination because it happens with this +zStart.

Offline Sorunome

  • Fox Fox Fox Fox Fox Fox Fox!
  • Support Staff
  • LV13 Extreme Addict (Next: 9001)
  • *************
  • Posts: 7918
  • Rating: +374/-13
  • Derpy Hooves
    • View Profile
    • My website! (You might lose the game)
Re: Faster Flash Access for the 83+/84+
« Reply #44 on: September 10, 2013, 07:45:50 am »
I personally avoided using goto error during Axe compiling, because in many cases it scrolled forever through garbage for me anyway, so I had the habit to just quit then go edit my program afterward. :P
Same here :P
Quote
I wonder what in the faster flash program could be causing the errors, though... ???
Maybe a weird combination because it happens with this +zStart.
I used it with zstart (run on RAM clear) and axe and some other of thepengiuns OS mods.....no problems.

THE GAME
Also, check out my website
If OmnomIRC is screwed up, blame me!
Click here to give me an internet!