Author Topic: TI Nspire CX version downgrade  (Read 6938 times)

0 Members and 1 Guest are viewing this topic.

Offline Rykattanak

  • LV0 Newcomer (Next: 5)
  • Posts: 1
  • Rating: +0/-0
    • View Profile
TI Nspire CX version downgrade
« on: October 19, 2014, 03:15:32 pm »
Is it possible to downgrade the version of my TI Nspire CX calculator ? I've updated it to 3.9 by mistake, and now I want to downgrade it to 3.2 or smth like that, is it possible ?


Thank You.

Offline DJ Omnimaga

  • Clacualters are teh gr33t
  • CoT Emeritus
  • LV15 Omnimagician (Next: --)
  • *
  • Posts: 55942
  • Rating: +3154/-232
  • CodeWalrus founder & retired Omnimaga founder
    • View Profile
    • Dream of Omnimaga Music
Re: TI Nspire CX version downgrade
« Reply #1 on: October 20, 2014, 11:41:36 am »
It depends what hardware revision your calc has. If your serial number ends with letter J or higher, then it's impossible to downgrade. Otherwise, you need an Arduino or RS232-TTL serial interface found online like Ebay then follow tutorials that can be found in older topics to downgrade.
Now active at https://discord.gg/cuZcfcF (CodeWalrus server)

Offline Alex Twigg

  • LV1 Newcomer (Next: 20)
  • *
  • Posts: 6
  • Rating: +0/-0
  • This is not personal...
    • View Profile
Re: TI Nspire CX version downgrade
« Reply #2 on: October 22, 2014, 07:10:47 pm »
soo what if it end in a j like mine? what are the steps to downgrading it or a link? thanks
I use a calculator as a substitute for a book and I am still cool in school...

Offline DJ Omnimaga

  • Clacualters are teh gr33t
  • CoT Emeritus
  • LV15 Omnimagician (Next: --)
  • *
  • Posts: 55942
  • Rating: +3154/-232
  • CodeWalrus founder & retired Omnimaga founder
    • View Profile
    • Dream of Omnimaga Music
Re: TI Nspire CX version downgrade
« Reply #3 on: October 22, 2014, 08:21:01 pm »
With J hardware, if you got OS 3.9 then you are screwed. Sell your calculator or get a refund, explaining you chose the wrong calc, then buy an older one from the secondary market, asking the reseller about the serial number first.
Now active at https://discord.gg/cuZcfcF (CodeWalrus server)

Offline DJ Omnimaga

  • Clacualters are teh gr33t
  • CoT Emeritus
  • LV15 Omnimagician (Next: --)
  • *
  • Posts: 55942
  • Rating: +3154/-232
  • CodeWalrus founder & retired Omnimaga founder
    • View Profile
    • Dream of Omnimaga Music
Re: TI Nspire CX version downgrade
« Reply #4 on: November 03, 2014, 01:24:39 am »
soo what if it end in a j like mine? what are the steps to downgrading it or a link? thanks
Ok, forget what I just said in my last post, yesterday an utility to downgrade from OS 3.9 just got released: http://tiplanet.org/forum/viewtopic.php?p=172099&sid=fb36298f23817f0a43d587b870cf0c4b#p172099

Keep in mind, however, that hardware J only supports OS 3.6 and higher, so everytime you reboot your calculator, you will need to re-install Ndless, but at least it's better than nothing now. :P
Now active at https://discord.gg/cuZcfcF (CodeWalrus server)

Offline The_King

  • LV5 Advanced (Next: 300)
  • *****
  • Posts: 247
  • Rating: +6/-2
  • Ⓣⓗⓔ Ⓖⓐⓜⓔ ⓍⒹ
    • View Profile
Re: TI Nspire CX version downgrade
« Reply #5 on: November 03, 2014, 01:14:34 pm »
soo what if it end in a j like mine? what are the steps to downgrading it or a link? thanks
Ok, forget what I just said in my last post, yesterday an utility to downgrade from OS 3.9 just got released: http://tiplanet.org/forum/viewtopic.php?p=172099&sid=fb36298f23817f0a43d587b870cf0c4b#p172099

Keep in mind, however, that hardware J only supports OS 3.6 and higher, so everytime you reboot your calculator, you will need to re-install Ndless, but at least it's better than nothing now. :P

OR he can use nlaunch but only keep 3.6 os and delete the other one???

Offline Hayleia

  • Programming Absol
  • Coder Of Tomorrow
  • LV12 Extreme Poster (Next: 5000)
  • ************
  • Posts: 3367
  • Rating: +393/-7
    • View Profile
Re: TI Nspire CX version downgrade
« Reply #6 on: November 03, 2014, 04:04:10 pm »
Keep in mind, however, that hardware J only supports OS 3.6 and higher
Hardware J actually supports 3.2.3 and higher but yeah, as far as Ndless is concerned, we can say "3.6 and higher".

OR he can use nlaunch but only keep 3.6 os and delete the other one???
nlaunch doesn't work on hardware J as far as I know.

But yeah, as DJ_O said, you can now downgrade from 3.9 to 3.6 and use Ndless 3.6.
I own: 83+ ; 84+SE ; 76.fr ; CX CAS ; Prizm ; 84+CSE
Sorry if I answer with something that seems unrelated, English is not my primary language and I might not have understood well. Sorry if I make English mistakes too.

click here to know where you got your last +1s