Author Topic: TI-84 ROM image problem  (Read 2914 times)

0 Members and 1 Guest are viewing this topic.

Offline juha.kivekas

  • LV0 Newcomer (Next: 5)
  • Posts: 4
  • Rating: +2/-0
    • View Profile
TI-84 ROM image problem
« on: April 03, 2013, 03:33:40 am »
Because getting a rom image seemed hard, i have been test-running my programs on the actual calculator (with no big problems so far).
Now, i'd like to do some debugging. My problem flows kind of like a depth first search:
get debugger->get emulator->get wabbitemu->get ROM-image->get TiLP->get all dependencies->install TiLP->[problem HERE]

Seems like i'm missing package "libarchive".

I installed TiLP according to  what was told here:http://ourl.ca/12289

I dont know what "libarchive" is, but i tried to apt-get and it said:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package libarchive

Im running ubuntu 12.04
« Last Edit: April 03, 2013, 03:36:56 am by juha.kivekas »

Offline Lionel Debroux

  • LV11 Super Veteran (Next: 3000)
  • ***********
  • Posts: 2135
  • Rating: +290/-45
    • View Profile
    • TI-Chess Team
Re: TI-84 ROM image problem
« Reply #1 on: April 03, 2013, 03:56:44 am »
You need libarchive-dev :)
Are you using http://lpg.ticalc.org/prj_tilp/download/install_tilp.sh ? Modern versions list the packages one needs to install (build dependencies).
Member of the TI-Chess Team.
Co-maintainer of GCC4TI (GCC4TI online documentation), TILP and TIEmu.
Co-admin of TI-Planet.

Offline juha.kivekas

  • LV0 Newcomer (Next: 5)
  • Posts: 4
  • Rating: +2/-0
    • View Profile
Re: TI-84 ROM image problem
« Reply #2 on: April 03, 2013, 04:18:20 am »
Oh, that was a simple fix, it installed now :)
i was in fact using install_tilp.sh, but i wasn't playing enough attention.

Offline ralphdspam

  • LV8 Addict (Next: 1000)
  • ********
  • Posts: 841
  • Rating: +38/-1
  • My name is actually Matt.
    • View Profile
Re: TI-84 ROM image problem
« Reply #3 on: April 03, 2013, 02:57:07 pm »
Im running ubuntu 12.04
It's good that you have compiled and installed TiLP, but it is in the apt repositories.
ld a, 0
ld a, a

Offline Lionel Debroux

  • LV11 Super Veteran (Next: 3000)
  • ***********
  • Posts: 2135
  • Rating: +290/-45
    • View Profile
    • TI-Chess Team
Re: TI-84 ROM image problem
« Reply #4 on: April 03, 2013, 03:04:58 pm »
Quote
It's good that you have compiled and installed TiLP, but it is in the apt repositories.
True, but the packages in the Debian/Ubuntu repositories for most versions are severely outdated (read: a version before I became the maintainer in June 2009). Nobody should use those, until they're upgraded to something sane :)
Member of the TI-Chess Team.
Co-maintainer of GCC4TI (GCC4TI online documentation), TILP and TIEmu.
Co-admin of TI-Planet.

Offline aeTIos

  • Nonbinary computing specialist
  • LV12 Extreme Poster (Next: 5000)
  • ************
  • Posts: 3913
  • Rating: +184/-32
    • View Profile
    • wank.party
Re: TI-84 ROM image problem
« Reply #5 on: April 04, 2013, 08:10:51 am »
It's recommended to build TiLP. How can one update the repos by the way
I'm not a nerd but I pretend:

Offline Lionel Debroux

  • LV11 Super Veteran (Next: 3000)
  • ***********
  • Posts: 2135
  • Rating: +290/-45
    • View Profile
    • TI-Chess Team
Re: TI-84 ROM image problem
« Reply #6 on: April 04, 2013, 08:44:00 am »
By maintaining the packages. alberthro has become their maintainer on the Debian side, and he has already started updating them (and sending me patches and complaints from the packaging tools so that I could fix the code / distribution), but package lists have been frozen for a while, until the next release of Debian is released (which should occur soon) :)
Member of the TI-Chess Team.
Co-maintainer of GCC4TI (GCC4TI online documentation), TILP and TIEmu.
Co-admin of TI-Planet.

Offline chickendude

  • LV8 Addict (Next: 1000)
  • ********
  • Posts: 816
  • Rating: +90/-1
  • Pro-Riot Squad
    • View Profile
Re: TI-84 ROM image problem
« Reply #7 on: April 04, 2013, 12:48:11 pm »
So a reasonably recent version of TiLP should soon be in the Ubuntu/Debian repositories? Cool! Do you know if there'll be support for any other distros?

Ah, i just found this thread: http://ourl.ca/18034 It seems TilEm2 should also soon be available from the repositories :D

EDIT: It appears there was also work being done to get TiLP into the Fedora repositories, i dunno if it's still being worked on or not:
http://www.cemetech.net/forum/viewtopic.php?t=6610
« Last Edit: April 04, 2013, 01:15:59 pm by chickendude »

Offline Lionel Debroux

  • LV11 Super Veteran (Next: 3000)
  • ***********
  • Posts: 2135
  • Rating: +290/-45
    • View Profile
    • TI-Chess Team
Re: TI-84 ROM image problem
« Reply #8 on: April 04, 2013, 01:12:05 pm »
Quote
So a reasonably recent version of TiLP should soon be in the Ubuntu/Debian repositories?
Hopefully, but that will require Debian 7.0 to be released first, and then alberthro will be able to re-upload the packages for review and sponsorship.

Quote
Do you know if there'll be support for any other distros?
At least Arch and OpenSUSE already have libti*/gfm/tilp packages. There are unofficial packages for Fedora ( http://www.cemetech.net/forum/viewtopic.php?t=6610 ), and now that the single biggest roadblock was cleared (usage of an embedded fork of minizip), it should be easier to make them official.

Quote
It seems TilEm2 should also soon be available from the repositories :D
Alongside libti*/gfm/tilp, yup, hopefully :)
Member of the TI-Chess Team.
Co-maintainer of GCC4TI (GCC4TI online documentation), TILP and TIEmu.
Co-admin of TI-Planet.