Author Topic: Battery will not charge, but maintains the same battery percentage  (Read 4145 times)

0 Members and 1 Guest are viewing this topic.

Offline annoyingcalc

  • LV10 31337 u53r (Next: 2000)
  • **********
  • Posts: 1953
  • Rating: +140/-72
  • Found in Eclipse.exe
    • View Profile
I plugged in my laptop into an outlet, and for an hour I used it I checked on the battery level, and it has stayed the same, the laptop thinks its charging. I have tried different outlets, with the same result, this laptop is only a few weeks old, and if I unplug it, the laptop doesn't turn off which it would do if it had a broken battery.

Windows 8.1 x64
8GB RAM
1TB Hard Drive
2.4Ghz Proccessor
Nvidia G755T 2Gb Video card
This used to contain a signature.

Offline The_King

  • LV5 Advanced (Next: 300)
  • *****
  • Posts: 247
  • Rating: +6/-2
  • Ⓣⓗⓔ Ⓖⓐⓜⓔ ⓍⒹ
    • View Profile
Re: Battery will not charge, but maintains the same battery percentage
« Reply #1 on: December 14, 2013, 10:14:17 pm »
which company is the laptop???

Offline Deep Toaster

  • So much to do, so much time, so little motivation
  • Administrator
  • LV13 Extreme Addict (Next: 9001)
  • *************
  • Posts: 8217
  • Rating: +758/-15
    • View Profile
    • ClrHome
Re: Battery will not charge, but maintains the same battery percentage
« Reply #2 on: December 17, 2013, 10:09:03 pm »
I plugged in my laptop into an outlet, and for an hour I used it I checked on the battery level, and it has stayed the same, the laptop thinks its charging. I have tried different outlets, with the same result, this laptop is only a few weeks old, and if I unplug it, the laptop doesn't turn off which it would do if it had a broken battery.
Maybe it's just the indicator that's stuck? My Ubuntu setup's power notification thing is broken half the time (basically gets stuck) and no matter how much I charge it it stays at the same number.

If I let the battery keep draining, it still maintains the same number but suddenly dies when the actual battery level hits zero. Is your laptop doing that?

I'm on some discontinued Acer V5-571 model by the way.
« Last Edit: December 17, 2013, 10:10:28 pm by Deep Thought »