Author Topic: Corrupted archive, help?  (Read 2583 times)

0 Members and 1 Guest are viewing this topic.

Offline Camdenmil

  • LV4 Regular (Next: 200)
  • ****
  • Posts: 121
  • Rating: +4/-0
    • View Profile
Corrupted archive, help?
« on: August 28, 2012, 08:09:26 pm »
I corrupted my VAT while messing with random sections of RAM. I was going to run calcsys to see what it said and then cause a ram clear to get back to normal. I accidentally launched zstart instead of calcsys and made the mistake of trying to exit. I think zstart tried to archive its appvar but failed because of the corrupted VAT. My calculator boots into the boot code (ON+DEL) just fine. Booting with ON+Clear and ON+Vars and both simultaneously just shows the ram clear screen and then crashes. When displaying the ram clear screen it only shows the 'R' in "RAM Cleared" below the calculator model. I'm using a TI84+SE with brandonW's patched 2.53. Is there any way to copy/fix my archive or do I need to do the ON+Mode flash clear/os install.
It is bad luck to be superstitious.

Offline Deep Toaster

  • So much to do, so much time, so little motivation
  • Administrator
  • LV13 Extreme Addict (Next: 9001)
  • *************
  • Posts: 8217
  • Rating: +758/-15
    • View Profile
    • ClrHome
Re: Corrupted archive, help?
« Reply #1 on: August 28, 2012, 09:59:49 pm »
Sounds like the OS is corrupted. If it were just the archive you should be able to boot with ON+CLEAR just fine, and the "RAM cleared" message certainly wouldn't be messed up like that.




Offline Camdenmil

  • LV4 Regular (Next: 200)
  • ****
  • Posts: 121
  • Rating: +4/-0
    • View Profile
Re: Corrupted archive, help?
« Reply #2 on: August 28, 2012, 11:51:32 pm »
Yeah, that's what I thought with the messed up ram clear screen. I resent an os and it worked. Does the tios only trust the vat even when it writes to os flash sectors?
« Last Edit: August 28, 2012, 11:51:51 pm by Camdenmil »
It is bad luck to be superstitious.