Author Topic: HP Prime corrupting programs  (Read 721 times)

0 Members and 2 Guests are viewing this topic.

Offline Scorpio72

  • LV0 Newcomer (Next: 5)
  • Posts: 2
  • Rating: +0/-0
    • View Profile
HP Prime corrupting programs
« on: July 17, 2018, 05:29:03 am »
Hello Everybody,

Last week I bought the HP Prime calculator (used but excellent condition still under warranty) and the FW version was 2016... so I updated it directly to the last firmware, 2018.02.12 1.4.1.13441)

Problems:

Once I transfer some programs from the HP Connectivity Kit to the calculator, the programs runs normally but after some time, they don't run anymore (yellow exclamation mark). When I edit the code and press check, I get Syntax error at line xx then at line xx and so on.

Example : "Sokobanbeta1" game. After installing the game, it works perfectly for let's say... 4 or 5 times. I turn off the calculator, and after a while, I power it on and the program is showing syntax errors in the code and wouldn't run.

The same for "moon" app and many more. It runs ok first times, then it starts to show syntax errors when edited.

Also, Codeviewer and code editor apps never worked at all but on the virtual calc on my pc, they run okay. The first ask me which prog I want edit then don't do anything, and the second, ask me what prog I want open and once I select, I get out of memory issue. (I have 17Mo RAM free and 193Mo on Flash)

Is it due to some bugs on the last firmware version? Do you have same issues?

Offline Scorpio72

  • LV0 Newcomer (Next: 5)
  • Posts: 2
  • Rating: +0/-0
    • View Profile
Re: HP Prime corrupting programs
« Reply #1 on: July 18, 2018, 03:25:31 am »
24 viewers and nobody is able to provide any idea...

Offline Xeda112358

  • Xombie. I am it.
  • Coder Of Tomorrow
  • LV12 Extreme Poster (Next: 5000)
  • ************
  • Posts: 4429
  • Rating: +696/-6
  • meow :3
    • View Profile
Re: HP Prime corrupting programs
« Reply #2 on: July 25, 2018, 05:52:53 pm »
Honestly, I had/have no idea. Something got corrupted, but whether or not it is software I could not tell you. Judging from some IRC conversation, it might be a hardware issue :|