Author Topic: TILP: beta-testing...  (Read 85970 times)

0 Members and 1 Guest are viewing this topic.

Offline DJ Omnimaga

  • Clacualters are teh gr33t
  • CoT Emeritus
  • LV15 Omnimagician (Next: --)
  • *
  • Posts: 55941
  • Rating: +3154/-232
  • CodeWalrus founder & retired Omnimaga founder
    • View Profile
    • Dream of Omnimaga Music
Re: TILP: beta-testing...
« Reply #45 on: April 19, 2010, 11:55:39 pm »
Are you sure gbc4nspire uses the exact same save file format for games, though?

Offline bwang

  • LV7 Elite (Next: 700)
  • *******
  • Posts: 634
  • Rating: +30/-11
    • View Profile
Re: TILP: beta-testing...
« Reply #46 on: April 20, 2010, 06:54:04 pm »
Yes, because sending the files via the official Nspire Link Software works.

Offline DJ Omnimaga

  • Clacualters are teh gr33t
  • CoT Emeritus
  • LV15 Omnimagician (Next: --)
  • *
  • Posts: 55941
  • Rating: +3154/-232
  • CodeWalrus founder & retired Omnimaga founder
    • View Profile
    • Dream of Omnimaga Music
Re: TILP: beta-testing...
« Reply #47 on: April 20, 2010, 07:40:07 pm »
aaah ok. Weird, then x.x

Offline Lionel Debroux

  • LV11 Super Veteran (Next: 3000)
  • ***********
  • Posts: 2135
  • Rating: +290/-45
    • View Profile
    • TI-Chess Team
Re: TILP: beta-testing...
« Reply #48 on: April 21, 2010, 01:30:23 pm »
Please e-mail me the file, so that I can try to reproduce ;)
Just to be sure: it's an Nspire, not an Nspire CAS ?
Member of the TI-Chess Team.
Co-maintainer of GCC4TI (GCC4TI online documentation), TILP and TIEmu.
Co-admin of TI-Planet.

Offline Lionel Debroux

  • LV11 Super Veteran (Next: 3000)
  • ***********
  • Posts: 2135
  • Rating: +290/-45
    • View Profile
    • TI-Chess Team
Re: TILP: beta-testing...
« Reply #49 on: April 25, 2010, 02:27:38 pm »
I can confirm that sending this file to my Nspire running OS 1.1 doesn't work either.
Member of the TI-Chess Team.
Co-maintainer of GCC4TI (GCC4TI online documentation), TILP and TIEmu.
Co-admin of TI-Planet.

Offline DJ Omnimaga

  • Clacualters are teh gr33t
  • CoT Emeritus
  • LV15 Omnimagician (Next: --)
  • *
  • Posts: 55941
  • Rating: +3154/-232
  • CodeWalrus founder & retired Omnimaga founder
    • View Profile
    • Dream of Omnimaga Music
Re: TILP: beta-testing...
« Reply #50 on: April 25, 2010, 02:35:50 pm »
So TiLP would only support newer OSes?

Offline Lionel Debroux

  • LV11 Super Veteran (Next: 3000)
  • ***********
  • Posts: 2135
  • Rating: +290/-45
    • View Profile
    • TI-Chess Team
Re: TILP: beta-testing...
« Reply #51 on: April 26, 2010, 12:05:26 pm »
Nope, communication between TILP and Nspire OS 1.1 "works" - just not on this file.
« Last Edit: April 26, 2010, 12:05:48 pm by Lionel Debroux »
Member of the TI-Chess Team.
Co-maintainer of GCC4TI (GCC4TI online documentation), TILP and TIEmu.
Co-admin of TI-Planet.

Offline willrandship

  • Omnimagus of the Multi-Base.
  • LV11 Super Veteran (Next: 3000)
  • ***********
  • Posts: 2953
  • Rating: +98/-13
  • Insert sugar to begin programming subroutine.
    • View Profile
Re: TILP: beta-testing...
« Reply #52 on: April 26, 2010, 12:25:59 pm »
It worked fine for sending with 2.0 for me on Linux Mint.

Offline Lionel Debroux

  • LV11 Super Veteran (Next: 3000)
  • ***********
  • Posts: 2135
  • Rating: +290/-45
    • View Profile
    • TI-Chess Team
Re: TILP: beta-testing...
« Reply #53 on: April 27, 2010, 01:32:38 am »
You mean that TILP II 1.14 was able to transfer a file to your Nspire / Nspire CAS running OS 2.0.x ?
Member of the TI-Chess Team.
Co-maintainer of GCC4TI (GCC4TI online documentation), TILP and TIEmu.
Co-admin of TI-Planet.

Offline willrandship

  • Omnimagus of the Multi-Base.
  • LV11 Super Veteran (Next: 3000)
  • ***********
  • Posts: 2953
  • Rating: +98/-13
  • Insert sugar to begin programming subroutine.
    • View Profile
Re: TILP: beta-testing...
« Reply #54 on: April 27, 2010, 11:54:43 am »
Well, it sent OS 2.0....I could try it later, but I was able to connect with it fine afterwards. Just a regular nspire. I used whatever Tilp II is latest in the repo, probably 1.14.

Offline Tribal

  • The Fallen
  • LV5 Advanced (Next: 300)
  • *
  • Posts: 218
  • Rating: +15/-1
    • View Profile
Re: TILP: beta-testing...
« Reply #55 on: July 15, 2010, 06:28:35 pm »
I was browsing around and saw this: SignTool

Apparently this file is also part of the Windows SDK and allows one to digitally sign files, would this work for the driver issues on x64 versions of Vista/7?

Offline DJ Omnimaga

  • Clacualters are teh gr33t
  • CoT Emeritus
  • LV15 Omnimagician (Next: --)
  • *
  • Posts: 55941
  • Rating: +3154/-232
  • CodeWalrus founder & retired Omnimaga founder
    • View Profile
    • Dream of Omnimaga Music
Re: TILP: beta-testing...
« Reply #56 on: July 19, 2010, 02:04:48 pm »
Mhmm interesting. I wonder how hard it is to use, though x.x

If it could solve the TILP + 64 bit issues, it would be nice if someone did a batch file doing the needed stuff for you

Offline Tribal

  • The Fallen
  • LV5 Advanced (Next: 300)
  • *
  • Posts: 218
  • Rating: +15/-1
    • View Profile
Re: TILP: beta-testing...
« Reply #57 on: July 23, 2010, 08:56:16 pm »
I found a small bug in v1.15, if you attempt to send a program by double-clicking on it when it's associated with TiLP, it will automatically crash.

EDIT: This seems to only occur if the 'USB scan at startup' option isn't checked, but it still crashes after it has been sent.
EDIT2: It also seems to crash when closing the GUI after a successful transfer.
I am on Win7 Ultimate x64
« Last Edit: July 23, 2010, 09:04:14 pm by Tribal »

Offline bwang

  • LV7 Elite (Next: 700)
  • *******
  • Posts: 634
  • Rating: +30/-11
    • View Profile
Re: TILP: beta-testing...
« Reply #58 on: July 23, 2010, 09:00:28 pm »
Lionel Debroux, did you ever fix the problem of files created by Visual Boy Advance not sending?

Offline Lionel Debroux

  • LV11 Super Veteran (Next: 3000)
  • ***********
  • Posts: 2135
  • Rating: +290/-45
    • View Profile
    • TI-Chess Team
Re: TILP: beta-testing...
« Reply #59 on: July 24, 2010, 02:18:12 am »
Thanks for the report, Tribal. I'll have to try reproducing that in a Windows 7 VM.

bwang: I've just tested again on Nspire 1.1.9253 and Nspire CAS 1.1.9170. Nope, my several Nspire-related fixes haven't fixed that one.
The final ACK is not received, it's either that there's a problem reading it or that it's not sent.
Member of the TI-Chess Team.
Co-maintainer of GCC4TI (GCC4TI online documentation), TILP and TIEmu.
Co-admin of TI-Planet.