Author Topic: 2009 Platformer Contest Poll - HYBRID (Lib-Enhanced BASIC)  (Read 8902 times)

0 Members and 1 Guest are viewing this topic.

Offline Eeems

  • Mr. Dictator
  • Administrator
  • LV13 Extreme Addict (Next: 9001)
  • *************
  • Posts: 6263
  • Rating: +318/-36
  • little oof
    • View Profile
    • Eeems
Re: 2009 Platformer Contest Poll - HYBRID (Lib-Enhanced BASIC)
« Reply #15 on: September 08, 2009, 09:35:03 am »
lol yeah...but I doubt it will at this rate....nobody seems to be voting
/e

Offline DJ Omnimaga

  • Clacualters are teh gr33t
  • CoT Emeritus
  • LV15 Omnimagician (Next: --)
  • *
  • Posts: 55941
  • Rating: +3154/-232
  • CodeWalrus founder & retired Omnimaga founder
    • View Profile
    • Dream of Omnimaga Music
Re: 2009 Platformer Contest Poll - HYBRID (Lib-Enhanced BASIC)
« Reply #16 on: September 08, 2009, 12:10:01 pm »
Altough it takes quite a while to test two entries with school and homework in the way x.x
Dream of Omnimaga

Offline Eeems

  • Mr. Dictator
  • Administrator
  • LV13 Extreme Addict (Next: 9001)
  • *************
  • Posts: 6263
  • Rating: +318/-36
  • little oof
    • View Profile
    • Eeems
Re: 2009 Platformer Contest Poll - HYBRID (Lib-Enhanced BASIC)
« Reply #17 on: September 08, 2009, 06:27:53 pm »
ah yeah...I see what you mean
of course I seem to have time...but again, of course this is my easy semester...
/e

Offline Eeems

  • Mr. Dictator
  • Administrator
  • LV13 Extreme Addict (Next: 9001)
  • *************
  • Posts: 6263
  • Rating: +318/-36
  • little oof
    • View Profile
    • Eeems
Re: 2009 Platformer Contest Poll - HYBRID (Lib-Enhanced BASIC)
« Reply #18 on: September 08, 2009, 07:14:46 pm »
Builderboy, I was wondering if when you release the game for real, if you could make it easier to save levelsets in things other then strings....
/e

Offline Builderboy

  • Physics Guru
  • CoT Emeritus
  • LV13 Extreme Addict (Next: 9001)
  • *
  • Posts: 5673
  • Rating: +613/-9
  • Would you kindly?
    • View Profile
Re: 2009 Platformer Contest Poll - HYBRID (Lib-Enhanced BASIC)
« Reply #19 on: September 08, 2009, 07:16:25 pm »
 ???

What do you mean, it saves them as lists.

Offline Eeems

  • Mr. Dictator
  • Administrator
  • LV13 Extreme Addict (Next: 9001)
  • *************
  • Posts: 6263
  • Rating: +318/-36
  • little oof
    • View Profile
    • Eeems
Re: 2009 Platformer Contest Poll - HYBRID (Lib-Enhanced BASIC)
« Reply #20 on: September 08, 2009, 07:24:20 pm »
grr, sorry I was trying to change that, but my interwebz is failing...so yeah, it wont let me fix it....but I meant that....
/e

Offline drummist

  • LV1 Newcomer (Next: 20)
  • *
  • Posts: 6
  • Rating: +0/-0
    • View Profile
Re: 2009 Platformer Contest Poll - HYBRID (Lib-Enhanced BASIC)
« Reply #21 on: September 08, 2009, 10:09:35 pm »
Has anyone tried these games in the TI-83 SDK Flash Debugger? A few years ago I reached the write limit on my TI-83SE, and since TI doesn't carry them anymore, I've been stuck with the simulator. Neither game seems to play well with the simulator. Do they just need a bit of polish, or is it a compatibility issue?

Eeems, Builderboy mentioned a problem with the game not liking his name. There are two domain errors in one of your substring calls before gameplay begins. I'm not sure how using "Eeems" fixed this though... Very impressive looking game, btw.

Offline Eeems

  • Mr. Dictator
  • Administrator
  • LV13 Extreme Addict (Next: 9001)
  • *************
  • Posts: 6263
  • Rating: +318/-36
  • little oof
    • View Profile
    • Eeems
Re: 2009 Platformer Contest Poll - HYBRID (Lib-Enhanced BASIC)
« Reply #22 on: September 08, 2009, 10:26:48 pm »
hmm, well it shouldn't be giving him the problems I made sure of that...but I'll check it again...it might just be that version...and I use Wabbit instead of the flash debugger...
/e

Offline DJ Omnimaga

  • Clacualters are teh gr33t
  • CoT Emeritus
  • LV15 Omnimagician (Next: --)
  • *
  • Posts: 55941
  • Rating: +3154/-232
  • CodeWalrus founder & retired Omnimaga founder
    • View Profile
    • Dream of Omnimaga Music
Re: 2009 Platformer Contest Poll - HYBRID (Lib-Enhanced BASIC)
« Reply #23 on: September 08, 2009, 11:09:13 pm »
WOW!!!!

Is that the pot smell from the appartment below that makes me feel high (yes, they smoke weed sometimes and it smells bad x.x) or did someone really managed to wear out his Flash ROM alerady???

No but seriously, I know this eventually must happen and with Casio AFX calcs, it requires 100x less Flash rewrites to do so, but doesn't the TI calcs require like 200000 Garbage Collections/Archive resets to wear out the Flash ROM? I was sure this would take at least 20-25 years to achieve such thing on a 83+, even more on a SE. I mean, you have no idea how much archive/unarchive/GC/resets my old 83+SE witnessed in 6 years, yet it still worked fine, except for draining batteries even while turned off.

ANyway back on topic, I actually used WabbitEmu to test all games besides Eeems, which required PindurTI, because I always had problems with Flash Debugger always taking a while to detect keypresses or running at weird speed.


Also welcome here, nice game btw  :)
« Last Edit: September 08, 2009, 11:13:42 pm by DJ Omnimaga »
Dream of Omnimaga

Offline drummist

  • LV1 Newcomer (Next: 20)
  • *
  • Posts: 6
  • Rating: +0/-0
    • View Profile
Re: 2009 Platformer Contest Poll - HYBRID (Lib-Enhanced BASIC)
« Reply #24 on: September 11, 2009, 09:14:07 am »
did someone really managed to wear out his Flash ROM alerady???

Hehe, well, I guess I'm not sure what else it could be. I've done several resets, and it'll run fine for about 5 minutes, and then it starts having fits and crashes every 3 seconds. After a few dozen resets, it'll seem fine again for a few minutes. When things are working, it'll complete a self-test without complaints, though...

I actually used WabbitEmu to test all games besides Eeems, which required PindurTI, because I always had problems with Flash Debugger always taking a while to detect keypresses or running at weird speed.

I'll check those out, but if they require ROMs, I know I won't be able to use my own. I have the same problems with the Flash Debugger. Unfortunately, most TI software isn't made to run with 64-bit OSes and connect with TI silver link cables.

Offline DJ Omnimaga

  • Clacualters are teh gr33t
  • CoT Emeritus
  • LV15 Omnimagician (Next: --)
  • *
  • Posts: 55941
  • Rating: +3154/-232
  • CodeWalrus founder & retired Omnimaga founder
    • View Profile
    • Dream of Omnimaga Music
Re: 2009 Platformer Contest Poll - HYBRID (Lib-Enhanced BASIC)
« Reply #25 on: September 11, 2009, 09:44:13 am »
Mhmm strange, are you sure it's because of the Flash being weared off and not a defect due to Flash memory or something else? The only way I could think that someone weared off his flash ROM in so short amount of time is running a program like 10 hours a day while spending your time doing other stuff like reading, gaming, chores, homework, and this program would keep archiving, unarchiving stuff a few times then prompts you for a GC where you would say yes and it would keep looping and looping
Dream of Omnimaga

Offline Builderboy

  • Physics Guru
  • CoT Emeritus
  • LV13 Extreme Addict (Next: 9001)
  • *
  • Posts: 5673
  • Rating: +613/-9
  • Would you kindly?
    • View Profile
Re: 2009 Platformer Contest Poll - HYBRID (Lib-Enhanced BASIC)
« Reply #26 on: September 11, 2009, 05:55:54 pm »
Maybe try reinstalling your OSif you haven't already?  It might be a rouge assembly program or something of the sort.  I've also had a few experiences where BASIC has managed to do strange things to my friends calcs (no games or asm).  One time was even so bad that I had to send them a copy of my OS.  But yeah, sometimes they just get messed up x.x

Offline drummist

  • LV1 Newcomer (Next: 20)
  • *
  • Posts: 6
  • Rating: +0/-0
    • View Profile
Re: 2009 Platformer Contest Poll - HYBRID (Lib-Enhanced BASIC)
« Reply #27 on: September 14, 2009, 02:14:55 pm »
I did re-install the OS a few times. Maybe it's worth mentioning that during a self test on the TI-83 SE, the first test is a clock rate test. Mine was not very consistent and became much slower when I installed OS 1.19 (from OS 1.18). Anyhow, sorry for hijacking this thread :/. Congratulations Builderboy.