Author Topic: Forum search broken?  (Read 3037 times)

0 Members and 1 Guest are viewing this topic.

Offline lkj

  • LV6 Super Member (Next: 500)
  • ******
  • Posts: 485
  • Rating: +58/-1
    • View Profile
Forum search broken?
« on: March 16, 2013, 11:40:43 am »
Today I tried to search the forum, but I got an error "You are not allowed to search for posts in this forum. "
Is it just intentionally disabled or did it break?

Offline Keoni29

  • LV11 Super Veteran (Next: 3000)
  • ***********
  • Posts: 2466
  • Rating: +291/-16
    • View Profile
    • My electronics projects at 8times8
Re: Forum search broken?
« Reply #1 on: March 16, 2013, 11:53:46 am »
Yeah it's broken. There is an alternative: custom google search
If you like my work: why not give me an internet?








Offline lkj

  • LV6 Super Member (Next: 500)
  • ******
  • Posts: 485
  • Rating: +58/-1
    • View Profile
Re: Forum search broken?
« Reply #2 on: March 16, 2013, 12:00:03 pm »
Yeah, it's just a bit annoying that you get a link to the wap version of omni.

Offline hellninjas

  • LV7 Elite (Next: 700)
  • *******
  • Posts: 625
  • Rating: +17/-0
    • View Profile
Re: Forum search broken?
« Reply #3 on: March 16, 2013, 05:41:45 pm »
Yah i've had this error for weeks now, I just kind-of ignored it and searched around myself xP

Offline Juju

  • Incredibly sexy mare
  • Coder Of Tomorrow
  • LV13 Extreme Addict (Next: 9001)
  • *************
  • Posts: 5730
  • Rating: +500/-19
  • Weird programmer
    • View Profile
    • juju2143's shed
Re: Forum search broken?
« Reply #4 on: March 16, 2013, 05:46:12 pm »
You can use this, it searches on Google without giving WAP versions of pages (thanks Vijkhoek :D).

http://megapowers.net/v/search.htm

Remember the day the walrus started to fly...

I finally cleared my sig after 4 years you're happy now?
THEGAME
This signature is ridiculously large you've been warned.

The cute mare that used to be in my avatar is Yuki Kagayaki, you can follow her on Facebook and Tumblr.

Offline Sorunome

  • Fox Fox Fox Fox Fox Fox Fox!
  • Support Staff
  • LV13 Extreme Addict (Next: 9001)
  • *************
  • Posts: 7920
  • Rating: +374/-13
  • Derpy Hooves
    • View Profile
    • My website! (You might lose the game)
Re: Forum search broken?
« Reply #5 on: March 16, 2013, 08:24:45 pm »
You can google for 'site:omnimaga.org <mysearchstring>'
Or just type in omnomirc '@omnimaga <mysearchstring>' (which does basically the same)

THE GAME
Also, check out my website
If OmnomIRC is screwed up, blame me!
Click here to give me an internet!

Offline epic7

  • Chopin!
  • LV11 Super Veteran (Next: 3000)
  • ***********
  • Posts: 2200
  • Rating: +135/-8
  • I like robots
    • View Profile
Re: Forum search broken?
« Reply #6 on: March 16, 2013, 09:01:02 pm »
However, sometimes @omnimaga fails as epically as the search bar :P

Offline pimathbrainiac

  • Occasionally I make projects
  • Members
  • LV10 31337 u53r (Next: 2000)
  • **********
  • Posts: 1731
  • Rating: +136/-23
  • dagaem
    • View Profile
Re: Forum search broken?
« Reply #7 on: March 16, 2013, 09:10:23 pm »
Only when Sorunome's bots are down tho :P
I am Bach.

Offline Darl181

  • «Yo buddy, you still alive?»
  • CoT Emeritus
  • LV12 Extreme Poster (Next: 5000)
  • *
  • Posts: 3408
  • Rating: +305/-13
  • VGhlIEdhbWU=
    • View Profile
    • darl181.webuda.com
Re: Forum search broken?
« Reply #8 on: March 16, 2013, 09:21:25 pm »
Was the rel=canonical thing ever figured out? Just did a search and the whole first page was ;wap pages 0.o
Vy'o'us pleorsdti thl'e gjaemue

Offline Sorunome

  • Fox Fox Fox Fox Fox Fox Fox!
  • Support Staff
  • LV13 Extreme Addict (Next: 9001)
  • *************
  • Posts: 7920
  • Rating: +374/-13
  • Derpy Hooves
    • View Profile
    • My website! (You might lose the game)
Re: Forum search broken?
« Reply #9 on: March 16, 2013, 10:37:15 pm »
that is googles fault, it keeps putting ;wap there......

THE GAME
Also, check out my website
If OmnomIRC is screwed up, blame me!
Click here to give me an internet!

Offline DJ Omnimaga

  • Former TI programmer
  • CoT Emeritus
  • LV15 Omnimagician (Next: --)
  • *
  • Posts: 55881
  • Rating: +3151/-232
  • CodeWalrus founder & retired Omnimaga founder
    • View Profile
    • DJ Omnimaga Music
Re: Forum search broken?
« Reply #10 on: March 16, 2013, 11:28:19 pm »
Yeah it happens with many other forums too (Invisionfree, Invisionboard, VBulletin, etc). It mostly caches those pages first because they're easier to crawl.

Offline TIfanx1999

  • ಠ_ಠ ( ͡° ͜ʖ ͡°)
  • CoT Emeritus
  • LV13 Extreme Addict (Next: 9001)
  • *
  • Posts: 6173
  • Rating: +191/-9
    • View Profile
Re: Forum search broken?
« Reply #11 on: March 18, 2013, 05:32:04 am »
So bump.. Can this be fixed? I was using our "search" feature up until recently and it is quite useful.

Offline Eeems

  • Mr. Dictator
  • Administrator
  • LV13 Extreme Addict (Next: 9001)
  • *************
  • Posts: 6233
  • Rating: +318/-36
  • little oof
    • View Profile
    • Eeems
Re: Forum search broken?
« Reply #12 on: March 18, 2013, 10:52:49 am »
So bump.. Can this be fixed? I was using our "search" feature up until recently and it is quite useful.
It's not broken, it's disabled on purpose. The SMF search functionality is really inefficient and causes the CPU to max out which slows down the whole site. If we leave it on there is a lot of negative impact on the users browsing the site. Namely huge slowdowns.
/e

Offline DJ Omnimaga

  • Former TI programmer
  • CoT Emeritus
  • LV15 Omnimagician (Next: --)
  • *
  • Posts: 55881
  • Rating: +3151/-232
  • CodeWalrus founder & retired Omnimaga founder
    • View Profile
    • DJ Omnimaga Music
Re: Forum search broken?
« Reply #13 on: March 18, 2013, 12:47:51 pm »
I checked SMF site and couldn't find an SMF 1.x Google mod so if that is ever added like on Cemetech that would need to be coded by the staff >.<

You could maybe add an extra ezblock on the search error page saying that search is disabled due to taking too much resources and use site:omnimaga <search query> on Google.
« Last Edit: March 18, 2013, 12:51:07 pm by DJ_O »

Offline TIfanx1999

  • ಠ_ಠ ( ͡° ͜ʖ ͡°)
  • CoT Emeritus
  • LV13 Extreme Addict (Next: 9001)
  • *
  • Posts: 6173
  • Rating: +191/-9
    • View Profile
Re: Forum search broken?
« Reply #14 on: March 18, 2013, 01:19:03 pm »
@Eeems:Ah ok. Thanks for the explanation. :)