Author Topic: Linux Mint help- driver issue?  (Read 1704 times)

0 Members and 1 Guest are viewing this topic.

Offline squidgetx

  • Food.
  • CoT Emeritus
  • LV10 31337 u53r (Next: 2000)
  • *
  • Posts: 1881
  • Rating: +503/-17
  • rawr.
    • View Profile
Linux Mint help- driver issue?
« on: January 07, 2013, 11:14:28 am »
Hi everyone,

Today I installed HL2 via wine and while it does run, it is unusably slow and the audio stutters a lot. On my WinXP partition however, it works more or less fine. I'm suspecting that Mint is not correctly identifying my old integrated crappy graphics card.

System Information:
Mint 13 MATE
Pentium 4 2.8GHz
1gb RAM

Relevant LSPCI output:
Code: [Select]
*-pci
          description: Host bridge
          product: 82915G/P/GV/GL/PL/910GL Memory Controller Hub
          vendor: Intel Corporation
          physical id: 100
          bus info: [email protected]:00:00.0
          version: 04
          width: 32 bits
          clock: 33MHz
          configuration: driver=agpgart-intel
          resources: irq:0
        *-display:0
             description: VGA compatible controller
             product: 82915G/GV/910GL Integrated Graphics Controller
             vendor: Intel Corporation
             physical id: 2
             bus info: [email protected]:00:02.0
             version: 04
             width: 32 bits
             clock: 33MHz
             capabilities: pm vga_controller bus_master cap_list rom
             configuration: driver=i915 latency=0
             resources: irq:16 memory:cfe00000-cfe7ffff ioport:cc00(size=8) memory:d0000000-dfffffff memory:cfdc0000-cfdfffff
        *-display:1 UNCLAIMED
             description: Display controller
             product: 82915G Integrated Graphics Controller
             vendor: Intel Corporation
             physical id: 2.1
             bus info: [email protected]:00:02.1
             version: 04
             width: 32 bits
             clock: 33MHz
             capabilities: pm bus_master cap_list
             configuration: latency=0
             resources: memory:cfe80000-cfefffff
...

The UNCLAIMED display1 is what's getting me at thinking that the graphics driver might be the problem. I've been on Intel's website, and apt is telling me I have xserver-xorg-video intel all up to date. Is this a driver problem? If so, how can I fix it? If not, what else could it be?

Thanks in advance

Offline Vogtinator

  • LV9 Veteran (Next: 1337)
  • *********
  • Posts: 1192
  • Rating: +108/-5
  • Instruction counter
    • View Profile
Re: Linux Mint help- driver issue?
« Reply #1 on: January 07, 2013, 12:22:01 pm »
lsmod?
glxgears?
glxinfo?

Quote
Today I installed HL2 via wine and while it does run, it is unusably slow and the audio stutters a lot. On my WinXP partition however, it works more or less fine
Wine and graphics drivers make windows games run much slower on every linux pc.
KDE Effects work without problems, no lags, but portal2 is unplayable on lowest settings. With Win7, it works > 60fps on mid.

Offline shmibs

  • しらす丼
  • Administrator
  • LV11 Super Veteran (Next: 3000)
  • ***********
  • Posts: 2132
  • Rating: +281/-3
  • try to be ok, ok?
    • View Profile
    • shmibbles.me
Re: Linux Mint help- driver issue?
« Reply #2 on: January 07, 2013, 04:03:17 pm »
the best way to "fix" it is to wait for the native port of HL2 :P

that being said, have you tried using playonlinux? there are lots of wine patches out there for making certain games work, and it collects them all (or lots, at least) in one place. it has scripts for installing HL2.