Author Topic: New Nspire CX - not detected in NSpire Student Software  (Read 56344 times)

0 Members and 1 Guest are viewing this topic.

Offline Atham

  • LV2 Member (Next: 40)
  • **
  • Posts: 34
  • Rating: +0/-0
    • View Profile
New Nspire CX - not detected in NSpire Student Software
« on: January 25, 2012, 01:43:24 pm »
Hello there,
I am new to this forum and I have made an account in hopes of resolving problems that I am experiencing.

I have a problem with my new TI nspire CX calculator. I can't seem to get it detected on the TI Nspire Student software that was given to me on the CD. That didn't work, so I installed the newest version of the software 3.1. Still no fix.

I am using Windows 7 64 Bit Ultimate as the operating system.

This is what I see in the connected handhelds window:


After a couple of clicking on the connected handhelds window I got this sort of message:


Then I ran the diagnostics tool that came with the software. This is what my results were:


Right at the beginning of the diagnostics test I got this message:



The calculator is detected in the device manager. It charges the calculator and the calculator itself is working. Here is a picture of the device manager:


In the attachment I have the diagnostics file from the diagnose tool.

Do you have any idea what could be going on? I am thinking this is a software issue but I am not sure. I hope there is a way to fix this. I like the calculator so far and I have read about the connections with the student software and all the features.

Thanks in advance

Alexander Tham

Offline Xeda112358

  • they/them
  • Moderator
  • LV12 Extreme Poster (Next: 5000)
  • ************
  • Posts: 4704
  • Rating: +719/-6
  • Calc-u-lator, do doo doo do do do.
    • View Profile
Re: New Nspire CX - not detected in NSpire Student Software
« Reply #1 on: January 25, 2012, 01:46:00 pm »
Hopefully there are folks that can help out here! (I am Thunderbolt on UTI, by the way)

Offline Atham

  • LV2 Member (Next: 40)
  • **
  • Posts: 34
  • Rating: +0/-0
    • View Profile
Re: New Nspire CX - not detected in NSpire Student Software
« Reply #2 on: January 25, 2012, 01:48:52 pm »
Yea, I hope too!

Offline Jim Bauwens

  • Lua! Nspire! Linux!
  • Editor
  • LV10 31337 u53r (Next: 2000)
  • **********
  • Posts: 1881
  • Rating: +206/-7
  • Linux!
    • View Profile
    • nothing...
Re: New Nspire CX - not detected in NSpire Student Software
« Reply #3 on: January 25, 2012, 01:53:32 pm »
Hi there and welcome :)

I don't use the student software much, but here are some questions/suggestions for you:

1) Do you have TiLP installed? TiLP and the student software don't work nicely together and can cause problems.
2) Did you try reseting your CX using the button on the back?
3) If it still doesn't work, you *might* try to run it as admin and see if it works then.

Offline Atham

  • LV2 Member (Next: 40)
  • **
  • Posts: 34
  • Rating: +0/-0
    • View Profile
Re: New Nspire CX - not detected in NSpire Student Software
« Reply #4 on: January 25, 2012, 01:57:18 pm »
TiLP is installed and I also have the student soft. How would I use TiLP though?

Offline Jim Bauwens

  • Lua! Nspire! Linux!
  • Editor
  • LV10 31337 u53r (Next: 2000)
  • **********
  • Posts: 1881
  • Rating: +206/-7
  • Linux!
    • View Profile
    • nothing...
Re: New Nspire CX - not detected in NSpire Student Software
« Reply #5 on: January 25, 2012, 01:58:38 pm »
Well, maybe you should remove it temporary, and see if the student software works then.
You can always reinstall it later :)

Offline Atham

  • LV2 Member (Next: 40)
  • **
  • Posts: 34
  • Rating: +0/-0
    • View Profile
Re: New Nspire CX - not detected in NSpire Student Software
« Reply #6 on: January 25, 2012, 01:59:38 pm »
I had the soft installed before TiLP and still had the same problems. I might uninstall the Student soft once I get to my PC.

Offline Jim Bauwens

  • Lua! Nspire! Linux!
  • Editor
  • LV10 31337 u53r (Next: 2000)
  • **********
  • Posts: 1881
  • Rating: +206/-7
  • Linux!
    • View Profile
    • nothing...
Re: New Nspire CX - not detected in NSpire Student Software
« Reply #7 on: January 25, 2012, 02:01:45 pm »
Okay, then TiLP will not be the problem.
TiLP is quite easy, I don't think I really need to explain it. Just choose your device in the settings, and you are ready to go :)

Edit:
Lionel Debrouxl has just notified me that TINC(L)S and TILP should work nicely together in the lastest versions :)
« Last Edit: January 25, 2012, 02:04:18 pm by jimbauwens »

Offline Atham

  • LV2 Member (Next: 40)
  • **
  • Posts: 34
  • Rating: +0/-0
    • View Profile
Re: New Nspire CX - not detected in NSpire Student Software
« Reply #8 on: January 25, 2012, 02:03:59 pm »
Remote controllingly uninstalling student soft.

Offline Lionel Debroux

  • LV11 Super Veteran (Next: 3000)
  • ***********
  • Posts: 2135
  • Rating: +290/-45
    • View Profile
    • TI-Chess Team
Re: New Nspire CX - not detected in NSpire Student Software
« Reply #9 on: January 25, 2012, 02:07:18 pm »
Quote
1) Do you have TiLP installed? TiLP and the student software don't work nicely together and can cause problems.
Nowadays (TILP II 1.16), they're supposed to be able to work side by side ;)
But beta-testing for this feature has been insufficient, in that most, if not all, beta-testers were already beta-testers for previous versions of TILP II. Maybe I screwed up something and it keeps working for them, while it shouldn't work for new installs (computers which have never had any version of TILP II and libusb before). That's why I've remained largely silent about the TILP II 1.16 release - even if that (and per-user settings on Windows, and drag & drop improvements, and CX screenshot & OS upgrade supports, etc.) would normally be a highly newsworthy item.

@Atham: indeed, if you had the problem before installing TILP, it's not TILP's fault.
Did you plug the calculator to the computer before installing either TINCS or TILP ? You shouldn't, because that causes Windows to install wrong drivers. Now, you need to force uninstall the driver in the Device Manager, and reinstall TINCS or TILP :)
« Last Edit: January 25, 2012, 02:21:24 pm by Lionel Debroux »
Member of the TI-Chess Team.
Co-maintainer of GCC4TI (GCC4TI online documentation), TILP and TIEmu.
Co-admin of TI-Planet.

Offline Atham

  • LV2 Member (Next: 40)
  • **
  • Posts: 34
  • Rating: +0/-0
    • View Profile
Re: New Nspire CX - not detected in NSpire Student Software
« Reply #10 on: January 25, 2012, 02:07:27 pm »
Going to try this tomorrow, as I have an assignment.

Offline Jim Bauwens

  • Lua! Nspire! Linux!
  • Editor
  • LV10 31337 u53r (Next: 2000)
  • **********
  • Posts: 1881
  • Rating: +206/-7
  • Linux!
    • View Profile
    • nothing...
Re: New Nspire CX - not detected in NSpire Student Software
« Reply #11 on: January 25, 2012, 02:19:30 pm »
Ah, thank you for the information Lionel :)
And thanks again for TiLP, without your work I wouldn't be productive at all on Linux!

Offline Atham

  • LV2 Member (Next: 40)
  • **
  • Posts: 34
  • Rating: +0/-0
    • View Profile
Re: New Nspire CX - not detected in NSpire Student Software
« Reply #12 on: January 26, 2012, 11:20:12 am »
How would I force the update of drivers?

Offline Atham

  • LV2 Member (Next: 40)
  • **
  • Posts: 34
  • Rating: +0/-0
    • View Profile
Re: New Nspire CX - not detected in NSpire Student Software
« Reply #13 on: January 27, 2012, 03:20:44 pm »
What drivers should I use. I mean what name of drivers.
« Last Edit: January 27, 2012, 03:29:04 pm by Atham »

Offline Deep Toaster

  • So much to do, so much time, so little motivation
  • Administrator
  • LV13 Extreme Addict (Next: 9001)
  • *************
  • Posts: 8217
  • Rating: +758/-15
    • View Profile
    • ClrHome
Re: New Nspire CX - not detected in NSpire Student Software
« Reply #14 on: January 27, 2012, 06:12:58 pm »
When you have your USB cable plugged in, uninstall the USB drivers and the ones by TiLP or the Nspire Student Software, if they're there.