Author Topic: TI-83+/84+ OS glitches compilation thread (all OSes)  (Read 79731 times)

0 Members and 3 Guests are viewing this topic.

Offline thepenguin77

  • z80 Assembly Master
  • LV10 31337 u53r (Next: 2000)
  • **********
  • Posts: 1591
  • Rating: +823/-5
  • The game in my avatar is bit.ly/p0zPWu
    • View Profile
Re: TI-83+/84+ OS glitches compilation thread (all OSes)
« Reply #165 on: May 24, 2012, 06:33:46 pm »
Sorry to throw Axe under the bus, but it's a program you all recognize and it uses the old unlock code.




Also, wabbitemu crashes when this glitch happens while real calculators tend to change their z-address.

Edit:
   The screenshot doesn't show it, but the calc screen turned off when I hit enter. I never actually saw the .666666666667
« Last Edit: May 24, 2012, 06:35:05 pm by thepenguin77 »
zStart v1.3.013 9-20-2013 
All of my utilities
TI-Connect Help
You can build a statue out of either 1'x1' blocks or 12'x12' blocks. The 1'x1' blocks will take a lot longer, but the final product is worth it.
       -Runer112

Offline blue_bear_94

  • LV8 Addict (Next: 1000)
  • ********
  • Posts: 801
  • Rating: +25/-35
  • Touhou Enthusiast / Former Troll / 68k Programmer
    • View Profile
Re: TI-83+/84+ OS glitches compilation thread (all OSes)
« Reply #166 on: July 03, 2012, 03:21:08 pm »
Sorry for the necropost but does the Bad Address error occur on all TI-84+ OSes while newer (1.19) TI-83+ OSes remain unaffected by it?
Due to dissatisfaction, I will be inactive on Omnimaga until further notice. (?? THP hasn't been much success and there's also the CE. I might possibly be here for a while.)
If you want to implore me to come back, or otherwise contact me, I can be found on GitHub (bluebear94), Twitter (@melranosF_), Reddit (/u/Fluffy8x), or e-mail (if you know my address). As a last resort, send me a PM on Cemetech (bluebear94) or join Touhou Prono (don't be fooled by the name). I've also enabled notifications for PMs on Omnimaga, but I don't advise using that since I might be banned.
Elvyna (Sunrise) 4 5%
TI-84+SE User (2.30 2.55 MP 2.43)
TI-89 Titanium User (3.10)
Casio Prizm User? (1.02)
Bag  東方ぷろの

Offline thepenguin77

  • z80 Assembly Master
  • LV10 31337 u53r (Next: 2000)
  • **********
  • Posts: 1591
  • Rating: +823/-5
  • The game in my avatar is bit.ly/p0zPWu
    • View Profile
Re: TI-83+/84+ OS glitches compilation thread (all OSes)
« Reply #167 on: July 03, 2012, 06:44:32 pm »
Sorry for the necropost but does the Bad Address error occur on all TI-84+ OSes while newer (1.19) TI-83+ OSes remain unaffected by it?

Every single OS ever made by TI suffers from this bug. Most likely it was created in their alpha builds, (unreleased 0.90 stuff), and the code has not ever been corrected. (Though it has been optimized lol)


Edit:
   You can't necropost in a sticky. Besides, I got really excited when I saw a new post here.
« Last Edit: July 03, 2012, 06:45:02 pm by thepenguin77 »
zStart v1.3.013 9-20-2013 
All of my utilities
TI-Connect Help
You can build a statue out of either 1'x1' blocks or 12'x12' blocks. The 1'x1' blocks will take a lot longer, but the final product is worth it.
       -Runer112

Offline blue_bear_94

  • LV8 Addict (Next: 1000)
  • ********
  • Posts: 801
  • Rating: +25/-35
  • Touhou Enthusiast / Former Troll / 68k Programmer
    • View Profile
Re: TI-83+/84+ OS glitches compilation thread (all OSes)
« Reply #168 on: July 03, 2012, 06:56:56 pm »
Maybe TI is trying to make us choose the TI-Nspire, LOL. Did you ever face the bug?
Due to dissatisfaction, I will be inactive on Omnimaga until further notice. (?? THP hasn't been much success and there's also the CE. I might possibly be here for a while.)
If you want to implore me to come back, or otherwise contact me, I can be found on GitHub (bluebear94), Twitter (@melranosF_), Reddit (/u/Fluffy8x), or e-mail (if you know my address). As a last resort, send me a PM on Cemetech (bluebear94) or join Touhou Prono (don't be fooled by the name). I've also enabled notifications for PMs on Omnimaga, but I don't advise using that since I might be banned.
Elvyna (Sunrise) 4 5%
TI-84+SE User (2.30 2.55 MP 2.43)
TI-89 Titanium User (3.10)
Casio Prizm User? (1.02)
Bag  東方ぷろの

Offline annoyingcalc

  • LV10 31337 u53r (Next: 2000)
  • **********
  • Posts: 1950
  • Rating: +140/-72
  • Found in Eclipse.exe
    • View Profile
Re: TI-83+/84+ OS glitches compilation thread (all OSes)
« Reply #169 on: July 03, 2012, 07:13:05 pm »
I had one once where the keys were messed up badly, example: if you pressed mode it would be like you hit trace
idk what caused it but somehow it got fixed
This used to contain a signature.

Offline blue_bear_94

  • LV8 Addict (Next: 1000)
  • ********
  • Posts: 801
  • Rating: +25/-35
  • Touhou Enthusiast / Former Troll / 68k Programmer
    • View Profile
Re: TI-83+/84+ OS glitches compilation thread (all OSes)
« Reply #170 on: July 03, 2012, 07:13:56 pm »
thepenguin77, you made a patch right? Any problems with it?
Due to dissatisfaction, I will be inactive on Omnimaga until further notice. (?? THP hasn't been much success and there's also the CE. I might possibly be here for a while.)
If you want to implore me to come back, or otherwise contact me, I can be found on GitHub (bluebear94), Twitter (@melranosF_), Reddit (/u/Fluffy8x), or e-mail (if you know my address). As a last resort, send me a PM on Cemetech (bluebear94) or join Touhou Prono (don't be fooled by the name). I've also enabled notifications for PMs on Omnimaga, but I don't advise using that since I might be banned.
Elvyna (Sunrise) 4 5%
TI-84+SE User (2.30 2.55 MP 2.43)
TI-89 Titanium User (3.10)
Casio Prizm User? (1.02)
Bag  東方ぷろの

Offline thepenguin77

  • z80 Assembly Master
  • LV10 31337 u53r (Next: 2000)
  • **********
  • Posts: 1591
  • Rating: +823/-5
  • The game in my avatar is bit.ly/p0zPWu
    • View Profile
Re: TI-83+/84+ OS glitches compilation thread (all OSes)
« Reply #171 on: July 03, 2012, 07:15:25 pm »
thepenguin77, you made a patch right? Any problems with it?

Nope it just fixes the glitch, and here's a link for all the future googlers.
zStart v1.3.013 9-20-2013 
All of my utilities
TI-Connect Help
You can build a statue out of either 1'x1' blocks or 12'x12' blocks. The 1'x1' blocks will take a lot longer, but the final product is worth it.
       -Runer112

Offline ztrumpet

  • The Rarely Active One
  • CoT Emeritus
  • LV13 Extreme Addict (Next: 9001)
  • *
  • Posts: 5712
  • Rating: +364/-4
  • If you see this, send me a PM. Just for fun.
    • View Profile
Re: TI-83+/84+ OS glitches compilation thread (all OSes)
« Reply #172 on: July 04, 2012, 02:55:11 am »
Sorry for the necropost but does the Bad Address error occur on all TI-84+ OSes while newer (1.19) TI-83+ OSes remain unaffected by it?

Every single OS ever made by TI suffers from this bug. Most likely it was created in their alpha builds, (unreleased 0.90 stuff), and the code has not ever been corrected. (Though it has been optimized lol)
Haha, really?  How many bytes did they shave off it?

   You can't necropost in a sticky. Besides, I got really excited when I saw a new post here.
Yeah, me too.  It's a pretty fun thread.

Offline ben_g

  • Hey cool I can set a custom title now :)
  • LV9 Veteran (Next: 1337)
  • *********
  • Posts: 1002
  • Rating: +125/-4
  • Asm noob
    • View Profile
    • Our programmer's team: GameCommandoSquad
Re: TI-83+/84+ OS glitches compilation thread (all OSes)
« Reply #173 on: July 04, 2012, 03:20:30 pm »
Every single OS ever made by TI suffers from this bug. Most likely it was created in their alpha builds, (unreleased 0.90 stuff), and the code has not ever been corrected. (Though it has been optimized lol)
so they made the glitch faster instaed of fixing it?
My projects
 - The Lost Survivors (Unreal Engine) ACTIVE [GameCommandoSquad main project]
 - Oxo, with single-calc multiplayer and AI (axe) RELEASED (screenshot) (topic)
 - An android version of oxo (java)  ACTIVE
 - A 3D collision detection library (axe) RELEASED! (topic)(screenshot)(more recent screenshot)(screenshot of it being used in a tilemapper)
Spoiler For inactive:
- A first person shooter with a polygon-based 3d engine. (z80, will probably be recoded in axe using GLib) ON HOLD (screenshot)
 - A java MORPG. (pc) DEEP COMA(read more)(screenshot)
 - a minecraft game in axe DEAD (source code available)
 - a 3D racing game (axe) ON HOLD (outdated screenshot of asm version)

This signature was last updated on 20/04/2015 and may be outdated

Offline thepenguin77

  • z80 Assembly Master
  • LV10 31337 u53r (Next: 2000)
  • **********
  • Posts: 1591
  • Rating: +823/-5
  • The game in my avatar is bit.ly/p0zPWu
    • View Profile
Re: TI-83+/84+ OS glitches compilation thread (all OSes)
« Reply #174 on: July 04, 2012, 03:21:52 pm »
Sorry for the necropost but does the Bad Address error occur on all TI-84+ OSes while newer (1.19) TI-83+ OSes remain unaffected by it?

Every single OS ever made by TI suffers from this bug. Most likely it was created in their alpha builds, (unreleased 0.90 stuff), and the code has not ever been corrected. (Though it has been optimized lol)
Haha, really?  How many bytes did they shave off it?

They didn't cut much off (like 10 bytes out of 200). They took some redundant code and made it into a subroutine. Honestly, I wouldn't be surprised if they made a script to do it for them.
zStart v1.3.013 9-20-2013 
All of my utilities
TI-Connect Help
You can build a statue out of either 1'x1' blocks or 12'x12' blocks. The 1'x1' blocks will take a lot longer, but the final product is worth it.
       -Runer112

Offline Yeong

  • Not a bridge
  • LV12 Extreme Poster (Next: 5000)
  • ************
  • Posts: 3739
  • Rating: +278/-12
  • Survivor of Apocalypse
    • View Profile
Re: TI-83+/84+ OS glitches compilation thread (all OSes)
« Reply #175 on: November 12, 2012, 07:15:29 pm »
OS 2.55 I think sigma glitches in MP (OS 2.55). It doesn't ram clear but it messes with contrast and "shifts" the screen downward. I don't know if it's just me, but it does it when n=1 to 9999.
Sig wipe!

Offline aeTIos

  • Nonbinary computing specialist
  • LV12 Extreme Poster (Next: 5000)
  • ************
  • Posts: 3913
  • Rating: +184/-32
    • View Profile
    • wank.party
Re: TI-83+/84+ OS glitches compilation thread (all OSes)
« Reply #176 on: November 13, 2012, 04:32:57 am »
Sorry to throw Axe under the bus, but it's a program you all recognize and it uses the old unlock code.




Also, wabbitemu crashes when this glitch happens while real calculators tend to change their z-address.

Edit:
   The screenshot doesn't show it, but the calc screen turned off when I hit enter. I never actually saw the .666666666667
What is a z-address?
I'm not a nerd but I pretend:

Offline Xeda112358

  • they/them
  • Moderator
  • LV12 Extreme Poster (Next: 5000)
  • ************
  • Posts: 4659
  • Rating: +718/-6
  • Calc-u-lator, do doo doo do do do.
    • View Profile
Re: TI-83+/84+ OS glitches compilation thread (all OSes)
« Reply #177 on: November 13, 2012, 07:46:35 am »
@Yeong: I could not reproduce it
@aeTIos: The lcd has the ability to have its pixels shifted down or up. For example, if you shift them up 8 pixels in the normal OS, headers in menus will appear on the bottom of the screen. There are a handful of games that use the z-address to create earthquake effects, too, since it is very fast compared to shifting the whole screen and then updating the LCD, this takes probably at most 38 t-states and however many wait states are required between each LCD write.

@thepenguin77: Z-Addressing appears to work in Wabbit now :D

Offline Yeong

  • Not a bridge
  • LV12 Extreme Poster (Next: 5000)
  • ************
  • Posts: 3739
  • Rating: +278/-12
  • Survivor of Apocalypse
    • View Profile
Re: TI-83+/84+ OS glitches compilation thread (all OSes)
« Reply #178 on: November 13, 2012, 07:57:48 am »
Yeah. The fraction patch fixed it. I'm pretty sure it was just my calc derping
Sig wipe!

Offline DJ Omnimaga

  • Former TI programmer
  • CoT Emeritus
  • LV15 Omnimagician (Next: --)
  • *
  • Posts: 55851
  • Rating: +3151/-232
  • CodeWalrus founder & retired Omnimaga founder
    • View Profile
    • DJ Omnimaga Music
Re: TI-83+/84+ OS glitches compilation thread (all OSes)
« Reply #179 on: January 31, 2013, 03:51:02 am »
Bump:

@Yeong: I could not reproduce it
@aeTIos: The lcd has the ability to have its pixels shifted down or up. For example, if you shift them up 8 pixels in the normal OS, headers in menus will appear on the bottom of the screen. There are a handful of games that use the z-address to create earthquake effects, too, since it is very fast compared to shifting the whole screen and then updating the LCD, this takes probably at most 38 t-states and however many wait states are required between each LCD write.

@thepenguin77: Z-Addressing appears to work in Wabbit now :D
Yep, I make heavy use of Z-addressing in Illusiat 2004, Reuben Quest and to a lesser extent ROL2/3. The reason why I stopped using it was because it only worked in 1 emulator: PindurTI, and it doesn't work on the TI-Nspire 84+ emulator.


Also:

Could someone check the list of bugs on the 1st post and post whatever is missing that was discovered in recent years? It would definitively be nice to complete that list, especially with the MP OSes. Please, only OS bugs, not bugs caused by ASM programs and stuff.

Also who thinks that most OS 2.43 and 2.55 MP bugs will still be present in OS 4.0 for the Color 84+? <_<
« Last Edit: January 31, 2013, 03:54:17 am by DJ_O »
In case you are wondering where I went, I left Omni back in 2015 to form CodeWalrus due to various reasons explained back then, but I stopped calc dev in 2016 and am now mostly active on the CW Discord server at https://discord.gg/cuZcfcF



Official Website |T-Shirt store | Reverbnation | Facebook | Youtube | Twitter | Spotify