Author Topic: Which Axe version do you use?  (Read 16007 times)

0 Members and 1 Guest are viewing this topic.

Offline Munchor

  • LV13 Extreme Addict (Next: 9001)
  • *************
  • Posts: 6199
  • Rating: +295/-121
  • Code Recycler
    • View Profile
Which Axe version do you use?
« on: June 05, 2011, 02:35:51 pm »
So, what Axe version do you use?

I don't expect many people to use the old versions but I still decided to put them in :)

Vote and discuss!

Offline Hot_Dog

  • If you can't find a cat, look for its tail.
  • CoT Emeritus
  • LV11 Super Veteran (Next: 3000)
  • *
  • Posts: 2966
  • Rating: +445/-10
    • View Profile
Re: Which Axe version do you use?
« Reply #1 on: June 05, 2011, 02:38:49 pm »
0.5.3b for two reasons:

1. Easier to develop axioms for it
2. ++ and -- ;)
There are people who can speak two languages, and they are called bilingual.  There are people who speak three languages and are therefore trilingual.  Then there are people who speak one language, and these people are called Americans.


Offline Munchor

  • LV13 Extreme Addict (Next: 9001)
  • *************
  • Posts: 6199
  • Rating: +295/-121
  • Code Recycler
    • View Profile
Re: Which Axe version do you use?
« Reply #2 on: June 05, 2011, 02:40:57 pm »
0.5.3b for two reasons:

1. Easier to develop axioms for it
2. ++ and -- ;)

I fancy ++ and -- too, and I use 0.5.3 too, although I guess not too many people use it because of the 16bit/16bit division bug.

SirCmpwn

  • Guest
Re: Which Axe version do you use?
« Reply #3 on: June 05, 2011, 02:41:50 pm »
I always use the latest version.

Offline Aichi

  • LV5 Advanced (Next: 300)
  • *****
  • Posts: 290
  • Rating: +76/-3
    • View Profile
    • Devrays
Re: Which Axe version do you use?
« Reply #4 on: June 05, 2011, 02:51:27 pm »
I'm still using 0.5.2 since I'm not sure if all bugs that Runer112 metioned are already fixed

Offline DJ Omnimaga

  • Former TI programmer
  • CoT Emeritus
  • LV15 Omnimagician (Next: --)
  • *
  • Posts: 55851
  • Rating: +3151/-232
  • CodeWalrus founder & retired Omnimaga founder
    • View Profile
    • DJ Omnimaga Music
Re: Which Axe version do you use?
« Reply #5 on: June 05, 2011, 03:04:16 pm »
None right now, but I voted 0.3.3, as this is the last version I ever used (to code).

Someone should try making a game in 0.0.5, just to show how far it can be pushed O.O. Password-based save files FTW :P
« Last Edit: June 05, 2011, 03:05:16 pm by DJ_O »
In case you are wondering where I went, I left Omni back in 2015 to form CodeWalrus due to various reasons explained back then, but I stopped calc dev in 2016 and am now mostly active on the CW Discord server at https://discord.gg/cuZcfcF



Official Website |T-Shirt store | Reverbnation | Facebook | Youtube | Twitter | Spotify

Offline ztrumpet

  • The Rarely Active One
  • CoT Emeritus
  • LV13 Extreme Addict (Next: 9001)
  • *
  • Posts: 5712
  • Rating: +364/-4
  • If you see this, send me a PM. Just for fun.
    • View Profile
Re: Which Axe version do you use?
« Reply #6 on: June 05, 2011, 04:28:43 pm »
I use whatever the latest version is.  For instance, when I made Axe Snake, the latest version was 0.3.2 so I used it. :)

The first real game that I remember was this one, which used Asm() for the buffer shifting that would now be easy with the Horizontal or Vertical commands.  It was made by Builderboy in version 0.0.4. O.O

Offline DJ Omnimaga

  • Former TI programmer
  • CoT Emeritus
  • LV15 Omnimagician (Next: --)
  • *
  • Posts: 55851
  • Rating: +3151/-232
  • CodeWalrus founder & retired Omnimaga founder
    • View Profile
    • DJ Omnimaga Music
Re: Which Axe version do you use?
« Reply #7 on: June 05, 2011, 04:30:12 pm »
Wow I wonder why I never included it in the tribute video. It's pretty great for early Axe, especially when there were no sprite support.
In case you are wondering where I went, I left Omni back in 2015 to form CodeWalrus due to various reasons explained back then, but I stopped calc dev in 2016 and am now mostly active on the CW Discord server at https://discord.gg/cuZcfcF



Official Website |T-Shirt store | Reverbnation | Facebook | Youtube | Twitter | Spotify

Offline ztrumpet

  • The Rarely Active One
  • CoT Emeritus
  • LV13 Extreme Addict (Next: 9001)
  • *
  • Posts: 5712
  • Rating: +364/-4
  • If you see this, send me a PM. Just for fun.
    • View Profile
Re: Which Axe version do you use?
« Reply #8 on: June 05, 2011, 04:31:55 pm »
Wow I wonder why I never included it in the tribute video. It's pretty great for early Axe, especially when there were no sprite support.
Probably because it was in the original Axe Parser thread, before Quigibo created the Your Projects - Post and Critique thread. ;)

Offline Hot_Dog

  • If you can't find a cat, look for its tail.
  • CoT Emeritus
  • LV11 Super Veteran (Next: 3000)
  • *
  • Posts: 2966
  • Rating: +445/-10
    • View Profile
Re: Which Axe version do you use?
« Reply #9 on: June 05, 2011, 04:34:47 pm »
Which reminds me...I'm going to write a review later this year, but I think Axe Parser is the greatest Ti-83+/Ti-84+ program ever written.  (And of course there's a lot of amazing ones out there)
There are people who can speak two languages, and they are called bilingual.  There are people who speak three languages and are therefore trilingual.  Then there are people who speak one language, and these people are called Americans.


Offline TIfanx1999

  • ಠ_ಠ ( ͡° ͜ʖ ͡°)
  • CoT Emeritus
  • LV13 Extreme Addict (Next: 9001)
  • *
  • Posts: 6173
  • Rating: +191/-9
    • View Profile
Re: Which Axe version do you use?
« Reply #10 on: June 06, 2011, 03:18:01 am »
0.5.3b for two reasons:

1. Easier to develop axioms for it
2. ++ and -- ;)

I fancy ++ and -- too, and I use 0.5.3 too, although I guess not too many people use it because of the 16bit/16bit division bug.

Actually if I remember correctly those bugs were fixed. I don't have an 83+ series calc. at the moment, but when I get my 84+SE(this week hoppefully) I'll be using the newest version.

Offline Freyaday

  • The One And Only Serial Time Killing Catboy-Capoeirista-Ballerino
  • LV10 31337 u53r (Next: 2000)
  • **********
  • Posts: 1970
  • Rating: +128/-15
  • I put on my robe and pixel hat...
    • View Profile
Re: Which Axe version do you use?
« Reply #11 on: June 06, 2011, 03:22:23 am »
I always use the latest version I can get my catboy hands on, and this is the longest poll I've ever seen.
In other news, Frey continues kicking unprecedented levels of ass.
Proud member of LF#N--Lolis For #9678B6 Names


I'm a performer at heart; I stole it last week.
My Artwork!

Offline aeTIos

  • Nonbinary computing specialist
  • LV12 Extreme Poster (Next: 5000)
  • ************
  • Posts: 3913
  • Rating: +184/-32
    • View Profile
    • wank.party
Re: Which Axe version do you use?
« Reply #12 on: June 06, 2011, 03:45:37 am »
The "what calculators do you own" poll is longer. I use 0.5.2 (Upgrading soon)
I'm not a nerd but I pretend:

Offline JustCause

  • CoT Emeritus
  • LV8 Addict (Next: 1000)
  • *
  • Posts: 810
  • Rating: +115/-5
    • View Profile
Re: Which Axe version do you use?
« Reply #13 on: June 06, 2011, 03:51:01 am »
0.4.8 for consistency reasons. I'll upgrade when my projects are done.
See you, space cowboy...

Offline Quigibo

  • The Executioner
  • CoT Emeritus
  • LV11 Super Veteran (Next: 3000)
  • *
  • Posts: 2031
  • Rating: +1075/-24
  • I wish real life had a "Save" and "Load" button...
    • View Profile
Re: Which Axe version do you use?
« Reply #14 on: June 06, 2011, 04:18:19 am »
Too bad there's no options for versions above 0.5.3 :P

There were also several unofficial versions that some people may have lying around becasue they requested to beta test new features, but I doubt anyone still uses those.  They had version numbers like "0.2.B" or "0.3.A" for instance.
___Axe_Parser___
Today the calculator, tomorrow the world!